Foros del Web » Creando para Internet » Flash y Actionscript »

SOS: no se ve contenido de Iframe en Firefox / Safari

Estas en el tema de SOS: no se ve contenido de Iframe en Firefox / Safari en el foro de Flash y Actionscript en Foros del Web. Hola a todos Abro este post para ver si alguien puede echarme un cable con ésto. Tengo un iframe en mi html que carga otro ...
  #1 (permalink)  
Antiguo 16/09/2007, 12:27
 
Fecha de Ingreso: agosto-2004
Mensajes: 129
Antigüedad: 13 años, 4 meses
Puntos: 0
SOS: no se ve contenido de Iframe en Firefox / Safari

Hola a todos
Abro este post para ver si alguien puede echarme un cable con ésto.

Tengo un iframe en mi html que carga otro html con una pelicula flash. El caso es que con IE va perfectamente, pero con Firefox y Opera el recuadro del iframe se queda en blanco, no carga nada.

Alguien sabe darme una solución a ésto? tengo que entregar la web mañana y me estoy volviendo loco!

Última edición por changingman; 16/09/2007 a las 19:23
  #2 (permalink)  
Antiguo 16/09/2007, 12:36
Avatar de manumaf  
Fecha de Ingreso: mayo-2007
Ubicación: Argentina
Mensajes: 853
Antigüedad: 10 años, 7 meses
Puntos: 6
Re: Iframe se ve blanco en Firefox y Opera

Pasa un poco de codigo y te digo por que es
  #3 (permalink)  
Antiguo 16/09/2007, 13:45
 
Fecha de Ingreso: agosto-2004
Mensajes: 129
Antigüedad: 13 años, 4 meses
Puntos: 0
Re: Iframe se ve blanco en Firefox y Opera

Hola manumaf, dime qué parte del código necesitas y te lo pongo.
Este es el código del IFRAME:

<iframe name="mainframe" src="noticias.html" width="580" height="600" border="0" frameborder="0" framespacing="0"></iframe>

y este el de la página a cargar "noticias.html"

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<meta http-equiv="Content-Type" content="text/html; charset=windows-1252">

<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
<title>Documento sin t&iacute;tulo</title>
<style type="text/css">
<!--
body {
margin-left: 0px;
margin-top: 0px;
margin-right: 0px;
margin-bottom: 0px;
}
.Estilo17 {font-size: 11px; font-family: Geneva, Arial, Helvetica, sans-serif; color: #333333; }
.Estilo18 {font-family: Geneva, Arial, Helvetica, sans-serif}
-->
</style>
<script src="file:///K|/quique/we2/Scripts/AC_RunActiveContent.js" type="text/javascript"></script>
</head>

<body background="imagenes/fondosecciones3.jpg" leftmargin="15" bgproperties="fixed">
<p>
<script type="text/javascript">
AC_FL_RunContent( 'codebase','http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,19,0','width','580','heigh t','600','src','noticias','quality','high','plugin spage','http://www.macromedia.com/go/getflashplayer','wmode','transparent','movie','not icias' ); //end AC code
</script><noscript><object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,19,0" width="580" height="600">
<param name="movie" value="noticias.swf">
<param name="quality" value="high">
<param name="wmode" value="transparent">

<embed src="noticias.swf" width="580" height="600" quality="high" pluginspage="http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash" wmode="transparent" ></embed>
</object>
</noscript>
</p>
</body>
</html>



Me acabo de dar cuenta de que la página noticias.html la carga, se veía blanco porque tenía la tabla (donde va el iframe) con fondo blanco, pero la he dejado sin color de fondo y ahora se ve la imagen que tiene de fondo ese html, pero en cambio no muestra el contenido, es un poco raro.

Al principio pensé que era porque en el html tengo un .swf, pero no, lo he quitado y he puesto un texto en html y tampoco lo muestra.

PD: pido disculpas si este no es el subforo más adecuado para este mensaje, lo puse aquí porque pensé que era problema del .swf, pero ya ví que no.

Última edición por changingman; 16/09/2007 a las 13:57
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 13:27.