Foros del Web » Creando para Internet » Flash y Actionscript »

Stop sound por medio del LINKAGE

Estas en el tema de Stop sound por medio del LINKAGE en el foro de Flash y Actionscript en Foros del Web. Buenas amigos, queria ver si alguien sabe como detener un sonido por medio del linkage. Esto necesito hacerlo porque estoy usando un sonido en muchas ...
  #1 (permalink)  
Antiguo 30/12/2005, 14:27
 
Fecha de Ingreso: octubre-2003
Mensajes: 304
Antigüedad: 14 años, 1 mes
Puntos: 0
Pregunta Stop sound por medio del LINKAGE

Buenas amigos, queria ver si alguien sabe como detener un sonido por medio del linkage.

Esto necesito hacerlo porque estoy usando un sonido en muchas partes de mi MC y apagandolo de la manera tradicional es complejo, pense que apagando los sonidos globalmente seria más practico.

Aclaración: no pongo stopAllSounds, porque algunos sonidos tiene que seguir andando.

Saludos y buen año para todos!!!
  #2 (permalink)  
Antiguo 30/12/2005, 15:13
 
Fecha de Ingreso: febrero-2005
Ubicación: MEXICO
Mensajes: 455
Antigüedad: 12 años, 10 meses
Puntos: 5
por aqui anda la respuesta http://www.aulaclic.es/flash8/t_6_1.htm
__________________

  #3 (permalink)  
Antiguo 02/01/2006, 08:49
 
Fecha de Ingreso: octubre-2003
Mensajes: 304
Antigüedad: 14 años, 1 mes
Puntos: 0
Cita:
Iniciado por cpucpu
por aqui anda la respuesta http://www.aulaclic.es/flash8/t_6_1.htm
CPUCPU, muchas gracias por responder.

Lei el articulo que me recomendaste, pero no encontre respuesta a mi pregunta.

Lo que yo necesito es controlar sonidos de una manera global, desde cualquier sector de mi movie clip, y necesito controlar esos sonidos independientemente.

Te agradesco que me hayas respondido!!
Saludos!
  #4 (permalink)  
Antiguo 02/01/2006, 18:58
Avatar de rod524  
Fecha de Ingreso: agosto-2004
Mensajes: 517
Antigüedad: 13 años, 4 meses
Puntos: 0
No se puede por medio del Linkage Name pero si por el Instance name.

Saludos.
  #5 (permalink)  
Antiguo 04/01/2006, 14:56
 
Fecha de Ingreso: octubre-2003
Mensajes: 304
Antigüedad: 14 años, 1 mes
Puntos: 0
MC donde utilizo el codigo es a su vez cargada en un simbolo de una MC "madre".

Amigos, estoy mas cerca de resolver esto, estoy usando este codigo para iniciar o detener un sonido, pero me surge el problema de que la MC donde utilizo el codigo es a su vez cargada en un simbolo de una MC "madre".
Probe con distintos direccionamientos (_root.MCsecundaria. , this) pero no anda, ahora si pruebo la MC "secundaria" sola (la que tiene el codigo que expongo más abajo) anda perfecto...

Código:
my_sound1 = new Sound;
my_sound1.attachSound("sound1");
my_sound1.start();
Alguien me podra ayudar en esto?
Muchas gracias!
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 13:25.