Foros del Web » Creando para Internet » Flash y Actionscript »

swf dentro de pafina asp que no se actualiza cuando hago un submit

Estas en el tema de swf dentro de pafina asp que no se actualiza cuando hago un submit en el foro de Flash y Actionscript en Foros del Web. Tengo una página callejero.asp donde va alojado un swf llamado mapa.swf . En la pagina callejero.asp tengo un formulario con una caja de texto (name=seccion) ...
  #1 (permalink)  
Antiguo 12/06/2003, 11:28
 
Fecha de Ingreso: mayo-2003
Ubicación: sevilla
Mensajes: 51
Antigüedad: 14 años, 7 meses
Puntos: 0
swf dentro de pafina asp que no se actualiza cuando hago un submit

Tengo una página callejero.asp donde va alojado un swf llamado mapa.swf .

En la pagina callejero.asp tengo un formulario con una caja de texto (name=seccion) y un botón submit cuya acción es enviarlo a la misma página callejero.asp

Al principio de la página asp recojo el valor del campo sección y lo meto en una variable llamada seccion. Si esta variable es distinta de vacio escribo su valor en un archivo de texto llamado mapa.txt

Por Ejemplo:

Si seccion=1 entonces en el fichero de texto queda:

&seccion=1&

En mapa.swf recojo la variable seccion del fichero de texto y según esta muestro un mapa u otro de la siguiente manera:

stop();
//Creo unas funciones para poderlas utilizar//
//función para limpiar el escenario de instancias de clip
function limpieza(){
primero.removeMovieClip();

}
/*en la línea de tiempo principal creamos una instancia
de símbolo vacía.
Para hacer más fácil su uso la incluimos en la función "vacía

function vacía(){
_root.createEmptyMovieClip("intercambio",0);
_root.intercambio._x = 550/2;
_root.intercambio._y = 346/2;
}
this.onLoad = function (){

limpieza();
vacía();
algo = new LoadVars();
algo.load("http://localhost/guiateonline/callejero_fin/mapa.txt",this,"POST");
algo.onLoad = function(){

_root.intercambio.attachMovie("mv"+String(this.sec cion),"primero",0);
_root.intercambio._xscale = 600;
_root.intercambio._yscale = 600;
_root.intercambio._x = 550/2;
_root.intercambio._y = 346/2;
_root.intercambio.setMask(masca);
};


};




Bueno pues ahora viene mi problemón.

El swf por si solo va bien, pero cuando esta en la página asp no actualiza.No sé como solucionarlo.
He probado varias cosas de caché de navegador pero nada.

A ver si me pueden ayudar.
Que me echan del currrrrrrrrrrooooo¡¡¡¡.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 17:59.