Foros del Web » Creando para Internet » Flash y Actionscript »

swf, que al cargarlo en mc se carga mal

Estas en el tema de swf, que al cargarlo en mc se carga mal en el foro de Flash y Actionscript en Foros del Web. hice un pequeño mc animado para anunciar pagina en obras... al cargarlo en la pagina de inicio se carga mal. Compruebo el swf y funciona ...
  #1 (permalink)  
Antiguo 06/05/2007, 14:36
 
Fecha de Ingreso: marzo-2007
Mensajes: 31
Antigüedad: 10 años, 8 meses
Puntos: 0
swf, que al cargarlo en mc se carga mal

hice un pequeño mc animado para anunciar pagina en obras... al cargarlo en la pagina de inicio se carga mal. Compruebo el swf y funciona ok, pero una vez metido en el fla, no se carga bien le faltan elementos... esto como puede arreglarse ?

Gracias de antemano. UN NOVATOOOOOOOO
  #2 (permalink)  
Antiguo 06/05/2007, 19:41
 
Fecha de Ingreso: agosto-2006
Mensajes: 4
Antigüedad: 11 años, 4 meses
Puntos: 0
Re: swf, que al cargarlo en mc se carga mal

Mal en que sentido? no se ve? se escala mal? usaste la opcion de publicacion del flash?
no entiendo lo de "una vez metido en el fla..." estas cargando un clip dentro de otro clip?

saludos
  #3 (permalink)  
Antiguo 07/05/2007, 03:08
 
Fecha de Ingreso: marzo-2007
Mensajes: 31
Antigüedad: 10 años, 8 meses
Puntos: 0
Re: swf, que al cargarlo en mc se carga mal

A ver si me explico bien. -SOY MU NOVATO-.
hice un swf -"obras"-, que es una animacion para indicar que la pagina -"prueba"-esta en obras... bien en la pagina inicial -"prueba"- quiero que aparezca este swf situado en un punto, pues yo lo importo a la biblioteca, como swf y luego lo coloco en una capa de -"prueba"-. Al importarlo, ya me sale mal, le faltan elementos de cuando construi el fla de "obras", y que al publicarlo estaba correcto. Es al importarlo cuando de desmadra... faltan elementos, una animacion con mascara desaparece... cosas asi
  #4 (permalink)  
Antiguo 07/05/2007, 10:29
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Re: swf, que al cargarlo en mc se carga mal

Hola eljamb:
La película no la importes a la Biblioteca de la principal, lo que tienes que hacer es cargarla dentro de un MC_vacío.
Vamos con un ejemplo:
Creamos un MC_vacío y al ponerlo en el escenario en el lugar donde queremos que se cargue la película externa, le ponemos como nombre de instancia: contenedor.
En el primer frame de la principal coloca éste código: contenedor.loadMovie("nombre.swf");

Espero haberte sido de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 13:01.