Foros del Web » Creando para Internet » Flash y Actionscript »

Swf Slideshow con XML embebido en Flash CS4

Estas en el tema de Swf Slideshow con XML embebido en Flash CS4 en el foro de Flash y Actionscript en Foros del Web. Buenas a todos, este es mi primer post y espero puedan ayudarme. Estoy incursionando en la programacion Actionscript y me puse como objetivo simple cargar ...
  #1 (permalink)  
Antiguo 29/12/2009, 16:32
 
Fecha de Ingreso: diciembre-2009
Mensajes: 1
Antigüedad: 10 años, 9 meses
Puntos: 0
De acuerdo Swf Slideshow con XML embebido en Flash CS4

Buenas a todos, este es mi primer post y espero puedan ayudarme.
Estoy incursionando en la programacion Actionscript y me puse como objetivo simple cargar una galeria de fotos dentro de una pagina echa en Flash CS4.

Cree mi slideshow con Flash Slideshow Maker Professional el cual me generó una serie de carpetas y archivos ya conocidos para mi, los cuales ubique en una carpeta en mi escritorio nombrada Galeria. Ahi dentro tengo:

Galeria/res
Galeria/slides (aqui estan las imagenes)
Galeria/thumbs (aqui estan las minuaturas)
Galeria/fs_aux.html
Galeria/slides.htm (indice de ubicacion de imagenes y thums, ademas de algunos datos de componentes, posicion, etc, creo que todos conocen este tipo de archivo)
Galeria/slideshow.swf (lo que quiero embeber)

Usé el siguiente codigo el cual encontré en un tuto interesante en youtube :)

var Xpos:Number = 338;
var Ypos:Number = 30;
var swf:MovieClip;
var loader:Loader = new Loader();

var defaultSWF:URLRequest = new URLRequest("slideshow.swf");

loader.load(defaultSWF);
loader.x = Xpos;
loader.y = Ypos;
addChild(loader);

Ahora bien, guardo mi página Galeria (de momento estoy intentando hacer funcionar el slideshow en este FLA para luego volver a hacer los pasos en mi pagina de destino), publico y al abrir el SWF de nombre galeria.swf me muestra perfectamente el slideshow, carga las miniaturas, carga la primera de las imagenes, pero de slide nada, está estatico, no se mueve. Tiene navegabilidad en cuanto a pasar de una lista de miniaturas a otra (muestra de a 5) pero no inicia el slide.

Ejecutando slideshow.swf por si solo funciona bien, pero no al embeberlo en otro swf.

¿Quien puede explicarme qué estoy haciendo mal?

Desde ya mil gracias.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 10:21.