Foros del Web » Creando para Internet » Flash y Actionscript »

SWFObject deja de funcionar tras update de Flash

Estas en el tema de SWFObject deja de funcionar tras update de Flash en el foro de Flash y Actionscript en Foros del Web. Hoy encendí el PC de mi oficina y lo primero que me apareción fue un anuncio de Adobe para actualizar el Flash Player. Lo actualicé. ...
  #1 (permalink)  
Antiguo 18/02/2008, 10:23
Avatar de ASLAN  
Fecha de Ingreso: septiembre-2007
Mensajes: 419
Antigüedad: 10 años, 3 meses
Puntos: 2
Exclamación SWFObject deja de funcionar tras update de Flash

Hoy encendí el PC de mi oficina y lo primero que me apareción fue un anuncio de Adobe para actualizar el Flash Player.
Lo actualicé.
Al visitar algunos de mis sitios web con IE me encontré que dejó de funcionar el SWFObject.
Alguna idea de cómo solucionar el problema ???
Alguna alternativa probada a SWFObject ???
Gracias de antemano

ASLAN
__________________
Registros Akáshicos
  #2 (permalink)  
Antiguo 18/02/2008, 10:39
 
Fecha de Ingreso: febrero-2006
Mensajes: 104
Antigüedad: 11 años, 9 meses
Puntos: 0
Re: SWFObject deja de funcionar tras update de Flash

Hola Aslan
Por lo general el SWF Object no se malogra, en todo caso podrías volver a bajartelo y chankarlo, si mencionas que no funciona porque no ves los SWF en tu PC puede ser por la memoria cache, puedes limpiar todos los temporales y cookies e intentar de nuevo pues el adobe flash ya lo tienes instalado...prueba con ello a ver que pasa..

Lo otro seria que tu script que va en el body para usar el SWFobject no este bien escrito y por ello no veas el SWF en pantalla cosa que por lo que mencionas al parecer no es ese el problema, de todos modos si gustas escribe tu script aqui y te menciono si esta correcto...ahora bien si antes veias el SWF y ahora no lo ves y no has cambiado el script solo podria ser por los temporales asumo...prueba visitar la misma pagina desde otra maquina...

Un saludo
Qualito
  #3 (permalink)  
Antiguo 18/02/2008, 11:03
Avatar de ASLAN  
Fecha de Ingreso: septiembre-2007
Mensajes: 419
Antigüedad: 10 años, 3 meses
Puntos: 2
Re: SWFObject deja de funcionar tras update de Flash

No he cambiado nada de mis sitios web.
El viernes se veían normalmente desde esta máquina y hoy no.

Eliminé los temporales y sigue igual. Desde IE no se ven.
Desde Mozilla Firefox y Opera se ve todo con normalidad.

Creo que es alguna clase de incompatibilidad de SWFObject con la última actualización del flash player.
__________________
Registros Akáshicos
  #4 (permalink)  
Antiguo 18/02/2008, 11:06
Avatar de ASLAN  
Fecha de Ingreso: septiembre-2007
Mensajes: 419
Antigüedad: 10 años, 3 meses
Puntos: 2
Re: SWFObject deja de funcionar tras update de Flash

A continuación dejo el código utilizado, el que se encuentra implementado en www.academiaholistica.com y www.comunidadholistica.org entre otras webs
Código:
<div id="flashcontent">
<strong>Necesita actualizar su Flash Player</strong>
</div>
<script type="text/javascript">
var so = new SWFObject("img/header.swf", "sotester", "743", "133", "9", "#0000FF");
so.write("flashcontent");
</script>
__________________
Registros Akáshicos
  #5 (permalink)  
Antiguo 18/02/2008, 11:26
nez
 
Fecha de Ingreso: junio-2005
Mensajes: 82
Antigüedad: 12 años, 6 meses
Puntos: 0
Re: SWFObject deja de funcionar tras update de Flash

Me sucede lo mismo. Lo he notado con particularidad en facebook: las aplicaciones en swf no funcionan. Tambien sucedió despues de actualizar el flash player y se presenta solo en IE. Desinstalaré y probaré instalando una version vieja del flash player. A propósito, alguien sabe donde se descargan versiones anteriores?.
  #6 (permalink)  
Antiguo 18/02/2008, 11:37
 
Fecha de Ingreso: febrero-2006
Mensajes: 104
Antigüedad: 11 años, 9 meses
Puntos: 0
Re: SWFObject deja de funcionar tras update de Flash

y que resultados obtuviste de visualizar tu pagina desde otra PC pero que tenga tambien IE7 ?
ves los SWF desde otra Pc o no los ves?

a la espera de tus comments
Slds
qualito
  #7 (permalink)  
Antiguo 18/02/2008, 11:45
nez
 
Fecha de Ingreso: junio-2005
Mensajes: 82
Antigüedad: 12 años, 6 meses
Puntos: 0
Re: SWFObject deja de funcionar tras update de Flash

pues me sucedio en dos pc en las que actualice flash player, sin embargo, acabo de revisar y ya no presenta el problema. No he hecho cambios en los navegadores, asi que quedo confundido. por si acaso, instala tambien el shockwave player.
Las pc que nunca actualizaron Flash player, no vi que presentaran ese problema.
Saludos.
  #8 (permalink)  
Antiguo 18/02/2008, 11:55
Avatar de ASLAN  
Fecha de Ingreso: septiembre-2007
Mensajes: 419
Antigüedad: 10 años, 3 meses
Puntos: 2
Re: SWFObject deja de funcionar tras update de Flash

Leyendo el blog oficial de SWFObject (en inglés) encontré que han tenido problemas con algunas nuevas versiones de flash player para lo cual existen dos modalidades para saltarse el chequeo de versión.

1. Vía URL, añadiendo ?detectflash=false

2. Vía HTML, sustituyendo la versión a chequear por false

En el ejemplo citado más arriba, el cambio sería el siguiente:
Código:
<div id="flashcontent">
<strong>Necesita actualizar su Flash Player</strong>
</div>
<script type="text/javascript">
var so = new SWFObject("img/header.swf", "sotester", "743", "133", "false", "#0000FF");
so.write("flashcontent");
</script>
Y PROBLEMA SOLUCIONADO

ASLAN
__________________
Registros Akáshicos
  #9 (permalink)  
Antiguo 18/02/2008, 12:01
 
Fecha de Ingreso: febrero-2006
Mensajes: 104
Antigüedad: 11 años, 9 meses
Puntos: 0
Re: SWFObject deja de funcionar tras update de Flash

Buen dato Aslan
Cambiar el numero de la version de flash sea "7" o "9"por el termino "false"...a tenerlo en consideracion entonces a los que se nos presentase ese inconveniente...

Saludos
Qualito
  #10 (permalink)  
Antiguo 23/02/2008, 18:34
Avatar de jim3481  
Fecha de Ingreso: agosto-2004
Ubicación: EEUU
Mensajes: 198
Antigüedad: 13 años, 3 meses
Puntos: 0
Re: SWFObject deja de funcionar tras update de Flash

Holas amigos, yo tenia el mismo problema en la pagina y lo arregle gracias a la solucion q posteo el amigo ASLAN

pero .. ahora tengo otro porblemon, algunas paginas con flash no las puedo ver .. x ejemplo en esta pagina

www.elcomercioperu.com me sale en la seccion de video de youtube

"This content requires the Flash Player. Download Flash Player. Already have Flash Player? Click here."

pero yo ya actualize el adobe flash , lo eh instalado varias veces pero aun asi me sigue arrojando el mismo error, no solo en esta web si no en algunas otras ..

Espero su ayuda.

Gracias
__________________
Así como es característica de los grandes pensadores decir mucho en pocas palabras, las mentes pequeñas se distinguen por valerse de muchas palabras para no decir nada. :arriba:

(Francois VI-Duque de la Rochefoulcauld)
  #11 (permalink)  
Antiguo 13/03/2008, 07:08
 
Fecha de Ingreso: marzo-2008
Mensajes: 1
Antigüedad: 9 años, 9 meses
Puntos: 0
Re: SWFObject deja de funcionar tras update de Flash

Hola a todos,

Estuve mirando en la web porque tenía el mismo problema descrito donde inició este foro y me encontré la siguiente página:

http://groups.google.com.bo/group/macromedia.flash.sitedesign/msg/acbe4b046a0ed697

Allí explican que hay que crear un archivo de texto, colocar el siguiente código:
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\ShockwaveFlash.ShockwaveFlash]

[HKEY_CLASSES_ROOT\ShockwaveFlash.ShockwaveFlash\CL SID]
@="{D27CDB6E-AE6D-11cf-96B8-444553540000}"
Y guardamos el archivo de texto. Luego cambiamos la extensión .txt a .reg y le damos doble click al archivo dándole SI o OK a todo lo que pregunta.

Y listo, con eso se me solucionó la vaina del falsh player que no me quería cargar bien aunque ya lo tenía actualizado.

Exitos!
  #12 (permalink)  
Antiguo 13/03/2008, 08:06
Avatar de Jowy  
Fecha de Ingreso: febrero-2007
Ubicación: En la red
Mensajes: 232
Antigüedad: 10 años, 9 meses
Puntos: 0
Re: SWFObject deja de funcionar tras update de Flash

Definitivamente Internet explorer es una pu#% mier%&! Llevo toda la mañana peleando con AC_RunActiveContent.js que tampoco va muy fino que digamos. Al final me he leido toda la conversación que indica luisdavidmr:

http://groups.google.com.bo/group/ma...be4b046a0ed697

y la verdad es que me ha confirmado una cosa de la cual tenía una ligera sospecha:

¡En mocosoft son unos chapuceros!

Al parecer los problemas vienen junto con la última actualización automática de IExplorer en XP. Al parecer al actualizar se borra la clave

Class "ShockwaveFlash.ShockwaveFlash"

del registro de windows y es sustituida por otra que deja inutilizable tanto el SWFObject como AC_RunActiveContent en las pelis hechas para las versiones mas recientes de FlashPlayer...

Solución: Desinstalar la ultima actualización o hacer lo que dice luisdavidmr y añadir la clave de nuevo al registro...
Si no funciona hay que desinstalar el flash player con el desinstalador:

http://kb.adobe.com/selfservice/view...nalId=tn_14157

y luego volverlo a instalar desde la web de adobe...



Enserio, me parece un bug ENORME o una maniobra de Microsoft para joder a la gente de adobe... esto es un putadón.. porque otro nombre no tiene. El que tenga webs hechas que utilicen la última versión de flash player que se prepare... Porque si todos los visitantes que tengan XP actualizado, y usen Internet Explorer (90%), tienen que hacer estos pasos (que va a ser que no), estamos apañaos.

Con casos como este hay muchas más razones para hablar de las excelencias de Firefox y recomendarlo a nuestros clientes...

Última edición por Jowy; 13/03/2008 a las 10:34
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta

SíEste tema le ha gustado a 3 personas (incluyéndote)




La zona horaria es GMT -6. Ahora son las 09:41.