Foros del Web » Creando para Internet » Flash y Actionscript »

telltarget no funciona

Estas en el tema de telltarget no funciona en el foro de Flash y Actionscript en Foros del Web. Hola amigos... En el primer fotograma tengo el siguiente codigo. En el segundo un goto1 <pre> </pre> al mismo nivel tengo un clip que tiene ...
  #1 (permalink)  
Antiguo 22/01/2002, 09:45
Avatar de oariasm  
Fecha de Ingreso: enero-2002
Ubicación: vivo en mi casa
Mensajes: 300
Antigüedad: 15 años, 11 meses
Puntos: 0
telltarget no funciona

Hola amigos...

En el primer fotograma tengo el siguiente codigo. En el segundo un goto1

<pre> </pre>

al mismo nivel tengo un clip que tiene 100 fotogramas de largo que se llama &quot;logoload&quot;.

Lo que yo quiero es que se vaya avanzando por el timeline del clip logoload segun el porciento que se halla cargado.

Por que no funciona?

Salu2


  #2 (permalink)  
Antiguo 22/01/2002, 09:47
Avatar de oariasm  
Fecha de Ingreso: enero-2002
Ubicación: vivo en mi casa
Mensajes: 300
Antigüedad: 15 años, 11 meses
Puntos: 0
Re: telltarget no funciona

el codigo es:

tkb=_root.getBytesTotal()/1024;
ckb=_root.getBytesLoaded()/1024;
kbciento=(ckb/tkb)*100;
totales=Number(int(tkb));
cargados=Number(int(ckb));
porciento=Number(int(kbciento));
tellTarget (&quot;/logoload&quot;) {
gotoAndStop (porciento);
}
if (porciento&gt;=100) {
tellTarget (&quot;_root&quot;) {
gotoAndPlay (&quot;intromenu&quot;, 1);
}
} else {
setProperty (&quot;barra&quot;, _xscale, porciento);
}
contador1=cargados.toString()+&quot; Kb.&quot;;
contador2=porciento.toString()+&quot; %&quot;;
  #3 (permalink)  
Antiguo 22/01/2002, 10:57
 
Fecha de Ingreso: diciembre-2001
Ubicación: Ciudad de México
Mensajes: 117
Antigüedad: 16 años
Puntos: 0
Re: telltarget no funciona

¿Qué tal si al clip que quieres que avance le pones el siguiente código?

onClipEvent(load){
stop()
_root.stop()
}
onClipEvent(enterFrame){
por= int(_root.getBytesLoaded()*100/_root.getBytesTotal());
gotoAndStop(por)
if(por == 100)_root.play();
}


amén.

// rolf :: senior product specialist
// <a href="http://alesys.net">alesys.net</a> :: <a href="http://tweened.net">tweened.com</a>
  #4 (permalink)  
Antiguo 23/01/2002, 15:20
Avatar de oariasm  
Fecha de Ingreso: enero-2002
Ubicación: vivo en mi casa
Mensajes: 300
Antigüedad: 15 años, 11 meses
Puntos: 0
Re: telltarget no funciona

Hola Rolf

Perdona pero no me aclaro...

Ese codigo que me brindas lo tengo que añadir al clip que quiero que avance.

Pero?, El codigo que ya tengo (el telltarget) es necesario o no?

Gracias
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 16:57.