Foros del Web » Creando para Internet » Flash y Actionscript »

Uso loadMovie...pero me sigue faltando algo

Estas en el tema de Uso loadMovie...pero me sigue faltando algo en el foro de Flash y Actionscript en Foros del Web. HOla compañeros!! estoy tratando de cargar un swf usando loadMovie(), cosa que si me funciona, hasta cierto punto, si carga la pelicula externa, lo que ...
  #1 (permalink)  
Antiguo 09/02/2006, 03:22
Avatar de ryu_on_ice  
Fecha de Ingreso: abril-2005
Mensajes: 314
Antigüedad: 12 años, 7 meses
Puntos: 0
Uso loadMovie...pero me sigue faltando algo

HOla compañeros!!

estoy tratando de cargar un swf usando loadMovie(), cosa que si me funciona, hasta cierto punto, si carga la pelicula externa, lo que me esta fallando es al momento de quitarla, ya que si me voya otro boton se queda ensima de todo, ya estube chekando todos los post relacionados con este tema, segui las recomendaciones propuestas y no me sale.......

Lo estoy haciendo asi...

en un boton del menu tiene este codigo....

on(press)
{
loadMovie("contacto.swf",2);// si pongo otro numero, me lo pone al frente de la principal a la que quiero cargarlo o de plano no lo carga...
}

y bueno hasta ahi creo que va bien, (creo) pero si agrego.....

on(press){
unloadMovie(2);
}
no carga nada.....


Ahora si lo hago como uds dicen, haciendo un MC vacio y ponerle nombre a la instanancia, para cargaralo y borrarlo, asi no mas no me carga nada...


saludos, y gracias de antemano!!
  #2 (permalink)  
Antiguo 09/02/2006, 06:26
Avatar de pituu2  
Fecha de Ingreso: abril-2004
Ubicación: paraná entre rios
Mensajes: 274
Antigüedad: 13 años, 7 meses
Puntos: 0
Una vez que cargo tu pelicula, los otros btn a que estan llamando a otro swf ?
Otra cosa la pelicula principal siempre va a ser la primera osea el nivel 0, de ahi en mas todas las que llames en otro nivel se cargaran por ensima de esta, si quieres que te remplace la pelicula principal, ( nivel 0 ), cuando cargues tu pelicula ext. tenes que llamarla al nivel 0.
__________________
pituu2
  #3 (permalink)  
Antiguo 09/02/2006, 11:20
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Hola ryu_on_ice:
El código para cargar por niveles es el siguiente:
on(release){
loadMovieNum("nombre.swf", número del nivel);
}
Si tu quieres reemplazar la película cargada solamente usa el mismo nivel de ese modo la anterior se descargará automáticamente.

Espero haberte sido de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
  #4 (permalink)  
Antiguo 09/02/2006, 23:45
Avatar de ryu_on_ice  
Fecha de Ingreso: abril-2005
Mensajes: 314
Antigüedad: 12 años, 7 meses
Puntos: 0
Uso loadMovie...pero me sigue faltando algo

OK compañeros GRACIAS por atender a este post!!
ya funciona...ya pude poner y quitar la pelicula externa

on(press){
loadMovie("contacto.swf","contenedor");
}

GRACIAS!!

Solo que me esta pasando un detalle, no se si se deba a que es un archivo externo....
Dicho archivo es el de contacto mail...tarda un buen rato en enviarlo y a veces no lo envia.....
a que creen que se deba???

Última edición por ryu_on_ice; 09/02/2006 a las 23:50
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 09:04.