Foros del Web » Creando para Internet » Flash y Actionscript »

A veces no carga completo...

Estas en el tema de A veces no carga completo... en el foro de Flash y Actionscript en Foros del Web. Estoy haciendo un formulario con php mysql y flash. Se trata de crear una ciudad guardando las ubicaciones y las preferencias (color, tipo, dueño, etc) ...
  #1 (permalink)  
Antiguo 05/01/2009, 16:18
Avatar de boby6killer  
Fecha de Ingreso: abril-2008
Mensajes: 81
Antigüedad: 9 años, 7 meses
Puntos: 1
A veces no carga completo...

Estoy haciendo un formulario con php mysql y flash. Se trata de crear una ciudad guardando las ubicaciones y las preferencias (color, tipo, dueño, etc) en la base de datos pero a veces el swf no se carga completamente, a veces faltan casas o no se cargan completamente. He notado que ejecutandolo desde el localhost no hay problema, pero al cargarlo en la red si me da problema. He revisado y no parece problema de la bdd o del php. Debo poner una barra de carga y esperar al swf para que se cargue completamente con los datos de mysql??? De ser asi, alguien sabe como hacerlo???
  #2 (permalink)  
Antiguo 06/01/2009, 13:40
Avatar de jahepi
Colaborador
 
Fecha de Ingreso: diciembre-2004
Ubicación: Querétaro
Mensajes: 1.124
Antigüedad: 13 años
Puntos: 43
Respuesta: A veces no carga completo...

Hola boby6killer !

Coloca la parte del script donde cargas los datos tanto de flash como de php para ver si existe algún problema.

Un saludote !
__________________
Una contraseña es como la ropa interior. No deberías dejarlas afuera a la vista de otras personas, deberías cambiarla regularmente, y ni se te ocurra prestarla a extraños.
  #3 (permalink)  
Antiguo 06/01/2009, 16:17
Avatar de boby6killer  
Fecha de Ingreso: abril-2008
Mensajes: 81
Antigüedad: 9 años, 7 meses
Puntos: 1
Respuesta: A veces no carga completo...

Gracias jahepi, uso unicamente el metodo get en php:

<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,29,0" width="50" height="50">
<param name="movie" value="avatar.swf?cg=<? echo $cg ?>&og=<? echo $og ?>&bg=<? echo $bg ?>">
<param name="quality" value="high">
<embed src="avatar.swf" quality="high" pluginspage="http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash" width="90" height="90"></embed>
</object>

y en actionscript simplemente hago esto:
var cg;
cg=_root.cg;
var og;
og=_root.og;
var bg;
bg=_root.bg;


Cuando tengo mas variables como en un sistema de odontograma, hago lo mismo pero voy abriendo de pagina en pagina y utilizo el objeto XML:
newCons18=new XML();
newCons18.load("odonto0.php?pieza=18&cdg="+pacient e+"&fecha="+fecha);

y voy dibujando de pieza dentaria en pieza dentaria.

Este problema me ha dado con conexiones lentas, creo que no le doy el tiempo necesario al swf para que se cargue completamente. Igualmente tengo problemas mas frecuentes con firefox que con ie

Gracias por tu respuesta, dame tu opinion jahepi para ver si me ayudas a solucionar
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 18:46.