Foros del Web » Creando para Internet » Flash y Actionscript »

Veinte precargas en 20 frames??

Estas en el tema de Veinte precargas en 20 frames?? en el foro de Flash y Actionscript en Foros del Web. Muy buenas, estoy intentando hacer lo que he visto en esta página: http://www.durczewski.com/ . Lo que quiero conseguir es lo que aqui hacen con las ...
  #1 (permalink)  
Antiguo 24/07/2003, 02:38
Avatar de mamono  
Fecha de Ingreso: julio-2003
Ubicación: Osorno
Mensajes: 9
Antigüedad: 14 años, 4 meses
Puntos: 0
Veinte precargas en 20 frames??

Muy buenas, estoy intentando hacer lo que he visto en esta página: http://www.durczewski.com/ . Lo que quiero conseguir es lo que aqui hacen con las fotografias. Hasta que no esta una fotografia, no puedes pinchar en la siguiente. Este es el codigo que he podido sacar con el SWFdescompiler.

//[Action in Frame 182]
stop();
getURL("phoTO/6.swf", "_level6");

// [Action in Frame 183]
stop();
getURL("phoTO/7.swf", "_level7");

// [Action in Frame 184]
stop();
getURL("phoTO/8.swf", "_level8");


Lo que me esta matando es (aunque sera una bobada ) es como "arranca" de nuevo??, como consigue que la pelicula de al play, porque no hay ningun getbytesloaded, ni funcion similar.

¿¿¿Alguna sugerencia???
  #2 (permalink)  
Antiguo 24/07/2003, 18:08
Avatar de pulento  
Fecha de Ingreso: noviembre-2002
Ubicación: En un pequeño, helado, obscuro reino... llamado Dinamarca.
Mensajes: 1.852
Antigüedad: 15 años, 1 mes
Puntos: 1
Cita:
Este es el codigo que he podido sacar con el SWFdescompiler.






Cita:
¿¿¿Alguna sugerencia???

Si ..... trata de hacerlo tu y aqui te ayudaremos...


Saludos
__________________
http://www.flotdesign.dk/
  #3 (permalink)  
Antiguo 25/07/2003, 01:25
Avatar de mamono  
Fecha de Ingreso: julio-2003
Ubicación: Osorno
Mensajes: 9
Antigüedad: 14 años, 4 meses
Puntos: 0
Claro que lo he intentado, hombre Lo puedes ver en la página www.cosmomedia.es , dentro de la sección de trabajos ( Las demas secciones estan en proceso, asi q no te fijes demasiado ). El efecto funciona, pero da fallos si aprietas antes de tiempo.

Graciassss
  #4 (permalink)  
Antiguo 25/07/2003, 04:29
Avatar de pulento  
Fecha de Ingreso: noviembre-2002
Ubicación: En un pequeño, helado, obscuro reino... llamado Dinamarca.
Mensajes: 1.852
Antigüedad: 15 años, 1 mes
Puntos: 1
Ok ... dos cosas..

Primero la foto que pones en el boton ..no deberia pesar mas de 1 k ya que por el tamaño la calidad grafica se veria bien de todas maneras y esto haria que cargaran mucho mas rapido.

Segundo al cargar tu mc por primera vez ..puedes hacerlo invisible y solamente visible cuando sea presionado el boton, y al mismo tiempo desabilitar el boton usando undefined , y habilitandolo cuando el total de carga sea igual al 100%.
De esta manera el usuario no podria ver una foto antes de que todas esten cargadas..

Saludos
__________________
http://www.flotdesign.dk/

Última edición por pulento; 25/07/2003 a las 04:33
  #5 (permalink)  
Antiguo 25/07/2003, 06:17
Avatar de mamono  
Fecha de Ingreso: julio-2003
Ubicación: Osorno
Mensajes: 9
Antigüedad: 14 años, 4 meses
Puntos: 0
Problema resuelto

Lo de las fotos pequeñas ya lo habia puesto, pesan 1,5 k cada uno, eso bien.
El problema lo he conseguido resolver de otra manera esta mañana. En las 20 "subpeliculas" he añadido un stop() en el primer frame ( Las peliculas tenian q entrar de izqda a dcha) y en cada boton de la página principal controlaba que al pinchar empezara en el frame dos de la pelicula. Asi no se pisan unas a otras.
Lo subire en una hora o asi, osea que si quieres lo podras ver, de todos modos me apunto tu solución que seguro que me vale para otra y muchas gracias. ciaaooo
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 09:54.