Foros del Web » Creando para Internet » Flash y Actionscript »

XML y Actionscript...solo funciona el primero

Estas en el tema de XML y Actionscript...solo funciona el primero en el foro de Flash y Actionscript en Foros del Web. Saludos, tengo un xml, con 65 elementos, lo raro es que solo me carga el primero, soyt nuevo en esto, a lo mejor me he ...
  #1 (permalink)  
Antiguo 01/04/2007, 20:43
Avatar de alucard3003  
Fecha de Ingreso: abril-2004
Mensajes: 148
Antigüedad: 13 años, 8 meses
Puntos: 0
XML y Actionscript...solo funciona el primero

Saludos, tengo un xml, con 65 elementos, lo raro es que solo me carga el primero, soyt nuevo en esto, a lo mejor me he equivocado en algo.
Uso esto para cargar la variable

Código PHP:
asunto_txt obj_xml.firstChild.childNodes[0].firstChild.childNodes[0].nodeValue
me funciona la el primer nodo, pero si intento con los siguientes, cualquiera...me da error...
el xml mas o menos es este
Código PHP:
<CURSOS>
  <
CURSO>
        <
titulo>Cambios de estado</titulo>
        <
resumen>Mundo Físico</resumen>
        <
grado>1º sec.</grado>
        <
capacidad>Comprensión de  información.</capacidad>
        <
resumen>Actividad que permite enlazar imágenes de fenómenos físicos con los cambios de estado que se producen.</resumen>
        <
simulador>FIS-01</simulador>
  </
CURSO>
  <
CURSO>
        <
titulo>Estados de la materia</titulo>
        <
resumen>Mundo Físico</resumen>
        <
grado>1º sec.</grado>
        <
capacidad>Comprensión de  información.</capacidad>
        <
resumen>Definición de los tres estados de la materia según el orden de sus moléculas.</resumen>
        <
simulador>FIS-02</simulador>
  </
CURSO>
</
CURSOS
cual podria ser el error?Porque como els digo lo raro es que me cargue el priumero mas no los siguientes.
Gracias!!!
__________________
X
  #2 (permalink)  
Antiguo 01/04/2007, 21:10
Avatar de alucard3003  
Fecha de Ingreso: abril-2004
Mensajes: 148
Antigüedad: 13 años, 8 meses
Puntos: 0
Re: XML y Actionscript...solo funciona el primero

bueno con esto me salen solamente los 3 primeros, es un avance...

Código PHP:
titulo _root.obj_xml.firstChild.childNodes[0].childNodes[3].firstChild.nodeValue
__________________
X
  #3 (permalink)  
Antiguo 01/04/2007, 21:26
Avatar de alucard3003  
Fecha de Ingreso: abril-2004
Mensajes: 148
Antigüedad: 13 años, 8 meses
Puntos: 0
Re: XML y Actionscript...solo funciona el primero

<CURSO>
<titulo>Cambios de estado</titulo>
<resumen>Mundo Físico</resumen>
<grado>1º sec.</grado>
<capacidad>Comprensión de información.</capacidad>
<resumen>Actividad que permite enlazar imágenes de fenómenos físicos con los cambios de estado que se producen.</resumen>
<simulador>FIS-01</simulador>
</CURSO>
ya vi mi error doble resumen!!!!!! todo por no hacer el xml manualmente...bueno para q se fijen :P
__________________
X
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 18:13.