Foros del Web » Creando para Internet » Flash y Actionscript »

XML generado por PHP (Mysql) y cargado en FLASH

Estas en el tema de XML generado por PHP (Mysql) y cargado en FLASH en el foro de Flash y Actionscript en Foros del Web. Mi problema es bastante simple. Genero mediante una consulta a base de datos un archivo XML nombresXML.php Pruebo en el navegador el nombresXML.php con el ...
  #1 (permalink)  
Antiguo 06/05/2004, 11:05
 
Fecha de Ingreso: noviembre-2002
Ubicación: LIMA
Mensajes: 652
Antigüedad: 15 años, 1 mes
Puntos: 1
XML generado por PHP (Mysql) y cargado en FLASH

Mi problema es bastante simple.
Genero mediante una consulta a base de datos un archivo XML nombresXML.php
Pruebo en el navegador el nombresXML.php con el apache en funcionamiento...y me sale el arbol de XML correctamente con el IExplorer.

Ahora, en mi archivo FLASH tengo el siguiente codigo

var doc=new XML();

doc.load("nombresXML.php");
doc.ignoreWhite=true;
doc.onLoad=haceralgo;
function haceralgo(){

trace(this.toString());
}


////////
Ahora, el problema q tengo es q se genera el evento onLoad, pero es como si no hubiese leido el archivo XML, generado por el PHP.
ACLARO, q antes probe el codigo con un XML estatico (es decir, no generado por el PHP) y la funcion haceralgo funciona correctamente, osea me muestra el texto correspondiente a ese XML.

Todos los archivos se ejecutan en el mismo folder (el de prueba del servidor de apache).
Espero alguien sepa.Muchas gracias.
  #2 (permalink)  
Antiguo 06/05/2004, 12:05
Avatar de TMeister
Crazy Coder
 
Fecha de Ingreso: enero-2002
Ubicación: En la Oficina
Mensajes: 2.880
Antigüedad: 15 años, 11 meses
Puntos: 193
Si lo estas ejecutando desde tu PC.. es decir con un servidor local prueba asi...

Código:
doc.load("http://localhost/carpeta/nombresXML.php");
Ya que, como lo tenias antes carga solo el archivo mas no ejecuta el PHP... ¿me explico.?

Saludos!!
  #3 (permalink)  
Antiguo 06/05/2004, 14:38
 
Fecha de Ingreso: noviembre-2002
Ubicación: LIMA
Mensajes: 652
Antigüedad: 15 años, 1 mes
Puntos: 1
si, gracias TMeister..al rato de publicar el post me di cuenta q no estaba llamando al servidor....de todas formas...ya tengo una nueva duda!..asi q me ire a postear al sector php...:D
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 23:04.