Foros del Web » Creando para Internet » Flash y Actionscript »

XML--Otro problema. Campo din en un clip

Estas en el tema de XML--Otro problema. Campo din en un clip en el foro de Flash y Actionscript en Foros del Web. Hola a todos, Hace poco tenia un problema con un campo de texto dinamico que no se veia, era por que no habia puesto nombres ...
  #1 (permalink)  
Antiguo 31/10/2003, 05:13
 
Fecha de Ingreso: octubre-2003
Ubicación: Castellon
Mensajes: 82
Antigüedad: 14 años, 1 mes
Puntos: 0
XML--Otro problema. Campo din en un clip

Hola a todos,
Hace poco tenia un problema con un campo de texto dinamico que no se veia, era por que no habia puesto nombres a las instancias y no habia especificado la ruta para la variable que extraia de un XML.
Bien, tras este pequeño recordatorio, llega mi nuevo problema:

He puesto el siguiente codigo:


function cargaXML() {
primerNivel = this.firstChild;
precios = primerNivel.childNodes;
n1 = precios[0].firstChild;
n2 = precios[1].firstChild;
n3 = precios[2].firstChild;
n4 = precios[3].firstChild;
n5 = precios[4].firstChild;
n6 = precios[5].firstChild;
n7 = precios[6].firstChild;
n8 = precios[7].firstChild;
precioALC = n1.nodeValue;
precioAGP = n2.nodeValue;
precioPMI = n3.nodeValue;
precioBCN = n4.nodeValue;
precioTFS = n5.nodeValue;
precioLPA = n6.nodeValue;
precioFUE = n7.nodeValue;
precioACE = n8.nodeValue;
logo_flota.ofi_precio.precioAGP = n2.nodeValue;
logo_flota.ofi_precio.precioPMI = n3.nodeValue;
limpiaXML();
}
function limpiaXML() {
delete primerNivel;
delete precios;
delete n1;
delete n2;
delete n3;
delete n4;
delete n5;
delete n6;
delete n7;
delete n8;
delete docXML;
}
var docXML = new XML();
docXML.ignoreWhite = true;
docXML.onLoad = cargaXML;
docXML.load("http://www.MI URL/precios.xml");



Los campos de texto que tienen que llenarse con precios estan dentro de un clip que se llama "ofi_precio " y este esta en otro que se llama "logo_flota " (nombres de las instancias, claro). EStos campos tienen las variables asignadas precioAGP y precioPMI .

Bien pues el precio aparece de forma intermitente un segundo y despues se va y no se ve mas.

NO LO ENTIENDO!

esto sucede cuando ejecuto el swf desde el flash (Ctrl+Intro) , pero cuando voy a la carpeta y lo ejecuto solo, no me sale nada de nada.


¿QUe hago mal ahora?
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 22:38.