Foros del Web » Creando para Internet » Flash y Actionscript »

XMLSocket no funciona al publicar

Estas en el tema de XMLSocket no funciona al publicar en el foro de Flash y Actionscript en Foros del Web. Buenas. Este es mi primer mensaje y el motivo del mismo es que tengo un problema con un chat en flash que estoy haciendo. El ...
  #1 (permalink)  
Antiguo 16/01/2007, 03:10
 
Fecha de Ingreso: enero-2007
Mensajes: 3
Antigüedad: 10 años, 10 meses
Puntos: 0
Exclamación XMLSocket no funciona al publicar

Buenas.
Este es mi primer mensaje y el motivo del mismo es que tengo un problema con un chat en flash que estoy haciendo.

El problema viene cuando publico el swf. La pelicula funciona correctamente, todo bien pero no me conecta con el servidor. Si cojo el mismo swf y lo ejecuto localmente o uso el Ejecutar del propio Flash 8 funciona correctamente, como un cristal, pero cuando lo meto dentro de un HTML y lo cuelgo, deja de funcionar.

Me carga la pelicula y en el momento de conectar en la barra de estado me aparece "Waiting 87.97.98...". Es como si no viera el servidor o hubiera un bloqueo delante.

He probado el servidor como digo ejecutando el cliente en local y funciona, incluso si entro al servidor por Telnet tambien me funciona asi que no tengo ningun firewall ni nada parecido.

Necesito darle al apache permisos para ejecutar sockets en flash?? Algun certificado raro que tenga que instalar?

Si alguien puediera echarme una mano se lo agradeceria...
Un abrazo.
  #2 (permalink)  
Antiguo 16/01/2007, 13:46
 
Fecha de Ingreso: enero-2007
Mensajes: 3
Antigüedad: 10 años, 10 meses
Puntos: 0
Re: XMLSocket no funciona al publicar

Nadie puede echarme una manilla?
  #3 (permalink)  
Antiguo 17/01/2007, 05:10
 
Fecha de Ingreso: enero-2007
Mensajes: 3
Antigüedad: 10 años, 10 meses
Puntos: 0
Re: XMLSocket no funciona al publicar

Bueno, pues en un foro me han ayudado a solucionar el problema.

Aqui pongo el link de un manual de CrossDomain Flash, para que el XMLSocket funcione.
moock.org/asdg/technotes/crossDomainPolicyFiles/

Pongo la solucion por si a alguien le pasa lo mismo.

Gracias por la ayuda
Un saludo.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 12:08.