Foros del Web » Creando para Internet » Flash y Actionscript »

Youtube en SWF Problema :-(

Estas en el tema de Youtube en SWF Problema :-( en el foro de Flash y Actionscript en Foros del Web. Hola Nuevament, Tengo varios botones en mi web que enlazan archivos swf que aparecen en el contenedor , acabo de hacer un nuevo swf donde ...
  #1 (permalink)  
Antiguo 15/10/2010, 13:08
Avatar de saulcuban  
Fecha de Ingreso: octubre-2010
Ubicación: Lima
Mensajes: 16
Antigüedad: 8 años, 10 meses
Puntos: 0
De acuerdo Youtube en SWF Problema :-(

Hola Nuevament, Tengo varios botones en mi web que enlazan archivos swf que aparecen en el contenedor , acabo de hacer un nuevo swf donde esta incrustado un video de yotube, el boton me funciona correctament y aparece el swf dentro del contenedor reproduce el video y todo Pero por ejemplo cuando me aburri de ver el video y lo dejo a medias, me voy a otro boton me dirige pero me doy cuenta que el video sigue sonando. Necesito que se detenga ese swf automaticamente cuando me dirijo a otro lugar de la web.

Estos son los script que uso para incrustar el video en el swf:

clip._alpha = 0;

var tinte:Number;
var tlist:Object = new Object();
tlist.onLoadInit = function() {
tinte = setInterval(checkVideo, 250);
}
var tload:MovieClipLoader = new MovieClipLoader();
tload.addListener(tlist);
tload.loadClip("http://www.youtube.com/v/SdmZMitG3hQ", clip);

function checkVideo() {
if (clip.isPlayerLoaded()) {
clip.setSize(420, 250);
clip._alpha = 100;
clearInterval(tinte);
}
}


Y ESTE ES EL SCRIPT PARA LLAMAR AL SWF DENTRO DEL CONTENEDOR:

on(release){_root.contenedor.loadMovie("galeria.sw f");}

  #2 (permalink)  
Antiguo 15/10/2010, 13:16
Avatar de mortiprogramador
Colaborador
 
Fecha de Ingreso: septiembre-2009
Ubicación: mortuoria
Mensajes: 3.805
Antigüedad: 9 años, 11 meses
Puntos: 214
Respuesta: Youtube en SWF Problema :-(

Hola
ya intentaste descargarlo?? unloadMovie()
saludos
__________________
"Si consigues ser algo más que un hombre, si te entregas a un ideal, si nadie puede detenerte, te conviertes en algo muy diferente."
Visita piggypon.com
  #3 (permalink)  
Antiguo 15/10/2010, 13:20
Avatar de saulcuban  
Fecha de Ingreso: octubre-2010
Ubicación: Lima
Mensajes: 16
Antigüedad: 8 años, 10 meses
Puntos: 0
De acuerdo Respuesta: Youtube en SWF Problema :-(

Cita:
Iniciado por mortiprogramador Ver Mensaje
Hola
ya intentaste descargarlo?? unloadMovie()
saludos

Comos de Descargarte el video??
Mi aprendizaje en as esta en proceso haber si me explicas :(
  #4 (permalink)  
Antiguo 15/10/2010, 15:23
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 16 años, 1 mes
Puntos: 406
Respuesta: Youtube en SWF Problema :-(

Hola saulcuban:
Si tú cargas todas las películas externas en el mismo MC_vacío: contenedor, al cargar la siguiente película, la anterior se descargará automáticamente.

Espero haberte sido de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
  #5 (permalink)  
Antiguo 15/10/2010, 15:29
Avatar de saulcuban  
Fecha de Ingreso: octubre-2010
Ubicación: Lima
Mensajes: 16
Antigüedad: 8 años, 10 meses
Puntos: 0
Desacuerdo Respuesta: Youtube en SWF Problema :-(

Cita:
Iniciado por bandit Ver Mensaje
hola saulcuban:
Si tú cargas todas las películas externas en el mismo mc_vacío: contenedor, al cargar la siguiente película, la anterior se descargará automáticamente.

Espero haberte sido de ayuda.
bandit tienes razon claro q se descarga pero elaudio sigue sonando como si aun estuviera play , presiono el mismo boton que me manda al swf del video, pero el video esta enstop sin embargo se escucha el audio del play anteriror q le di
  #6 (permalink)  
Antiguo 15/10/2010, 16:21
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 16 años, 1 mes
Puntos: 406
Respuesta: Youtube en SWF Problema :-(

Que raro, al descargarse la película que contiene el video, todo debe de desaparecer.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
  #7 (permalink)  
Antiguo 16/10/2010, 00:29
Avatar de saulcuban  
Fecha de Ingreso: octubre-2010
Ubicación: Lima
Mensajes: 16
Antigüedad: 8 años, 10 meses
Puntos: 0
Busqueda Respuesta: Youtube en SWF Problema :-(

Cita:
Iniciado por Bandit Ver Mensaje
Que raro, al descargarse la película que contiene el video, todo debe de desaparecer.
Hola Bandit mira este es el problema q me pasa

http://www.siprocor.com/web/youtube/youtube.html

DALE PLAY A UN VIDEO Y DESPUES A OTRO T DARASCUENTA Q EL AUDIO ANTERIOR SIG SONANDO ( por cierto me di cuenta tmb q cuando esta reproduciendoc el video mis sub-botones de la barra de menu q me ayudastes a funcionar no funcan en ese momento
  #8 (permalink)  
Antiguo 16/10/2010, 09:53
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 16 años, 1 mes
Puntos: 406
Respuesta: Youtube en SWF Problema :-(

Si dejas terminar al video no se produce ese problema.
1.- Prueba también colocar en cada .swf un video y cargarlos dentro del MC_vacío.
2.- Si tienes los videos, porque no usas el Componente FLVPlaybak para cargar tus videos y solamente necesitarías un sólo componente.

Espero haberte sido de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
  #9 (permalink)  
Antiguo 16/10/2010, 11:24
Avatar de saulcuban  
Fecha de Ingreso: octubre-2010
Ubicación: Lima
Mensajes: 16
Antigüedad: 8 años, 10 meses
Puntos: 0
Busqueda Respuesta: Youtube en SWF Problema :-(

Cita:
Iniciado por Bandit Ver Mensaje
Si dejas terminar al video no se produce ese problema.
1.- Prueba también colocar en cada .swf un video y cargarlos dentro del MC_vacío.
2.- Si tienes los videos, porque no usas el Componente FLVPlaybak para cargar tus videos y solamente necesitarías un sólo componente.

Espero haberte sido de ayuda.
Eh probado y no me jala el Playback te dejo el FL aki para qveas el problema esta es la pg web esta funcionando 3 botones ps para enviarte todos pesa mas
PRUEBA ASI :

1.- PRESIONA EL BOTON "NOSOTROS"
2. PRESIONA EL BOTON "GALERIA" AHY ESTA LA INCRUSTACION DEL VIDEO
3. DALE PLAY AL VIDEO Y EN PLENA REPRODUCCION DALE CLICK AL BOTON "NOSOTROS"
si t das cuenta el video aun esta sonando :( haber haber si me ayudas con la codificacion .

PDT: por cierto me dijieron q ponga ***.destroy(); para qse descarg pero en q part pongo ese codigo ??

el Link: http://www.megaupload.com/?d=QY3MN72I
PAZ Haber si melo reenvias de nuevo Gracias d toda forma
  #10 (permalink)  
Antiguo 17/10/2010, 13:05
Avatar de saulcuban  
Fecha de Ingreso: octubre-2010
Ubicación: Lima
Mensajes: 16
Antigüedad: 8 años, 10 meses
Puntos: 0
Busqueda Respuesta: Youtube en SWF Problema :-(

Cita:
Iniciado por Bandit Ver Mensaje
Si dejas terminar al video no se produce ese problema.
1.- Prueba también colocar en cada .swf un video y cargarlos dentro del MC_vacío.
2.- Si tienes los videos, porque no usas el Componente FLVPlaybak para cargar tus videos y solamente necesitarías un sólo componente.

Espero haberte sido de ayuda.
Hola Bandit t dejo el fla q pesa menos de 1 mb para no molestarte mucho con respecto al tema
[URL="http://www.forosdelweb.com/f16/youtube-swf-problema-851057/"]http://www.forosdelweb.com/f16/youtube-swf-problema-851057/[/URL]

este es el FLA q es mas liviano
[URL="http://www.megaupload.com/?d=3WFK3RSP"]http://www.megaupload.com/?d=3WFK3RSP[/URL]

Espero q me reenvies el fla con los codigos correctos si lo hize mal porfavor

juega con los botones "NOSOTROS" Y DALE PLAY AL VIDEO DEL BOTON "GALERIA", si vuelves a "NOSOTROS" seguira sonando :S
  #11 (permalink)  
Antiguo 17/10/2010, 13:21
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 16 años, 1 mes
Puntos: 406
Respuesta: Youtube en SWF Problema :-(

Hola saulcuban:
Ya te contesté a tu MP, en el cual te explico el porque de no poderte ayudar.

Saludos.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
  #12 (permalink)  
Antiguo 17/10/2010, 14:00
Avatar de saulcuban  
Fecha de Ingreso: octubre-2010
Ubicación: Lima
Mensajes: 16
Antigüedad: 8 años, 10 meses
Puntos: 0
Respuesta: Youtube en SWF Problema :-(

Cita:
Iniciado por Bandit Ver Mensaje
Hola saulcuban:
Ya te contesté a tu MP, en el cual te explico el porque de no poderte ayudar.

Saludos.

me puedes dar tu msn paraq me ayudes online ?

Etiquetas: actionscript2, as2, flash, youtube, botones
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 18:18.