Foros del Web » Creando para Internet » Herramientas y Software »

Error con netbeans

Estas en el tema de Error con netbeans en el foro de Herramientas y Software en Foros del Web. Hola recien instale el netbeans 6.9, pero tiene que haber un error ,porque cada vez que hago un zf show version , me sale el ...
  #1 (permalink)  
Antiguo 06/03/2010, 04:01
 
Fecha de Ingreso: agosto-2009
Mensajes: 138
Antigüedad: 9 años, 7 meses
Puntos: 0
Error con netbeans

Hola recien instale el netbeans 6.9, pero tiene que haber un error ,porque cada vez que hago un zf show version , me sale el siguiente error.
Código:
PHP Warning:  include_once(NetBeansCommandsProvider.php): failed to open stream: No such file or directory in C:\Zend\library\Zend\Loader.php on line 146

Warning: include_once(NetBeansCommandsProvider.php): failed to open stream: No such file or directory in C:\Zend\library\Zend\Loader.php on line 146
PHP Warning:  include_once(): Failed opening 'NetBeansCommandsProvider.php' for inclusion (include_path='C:\Zend\library;.;C:\php5\pear') in C:\Zend\library\Zend\Loader.php on line
 146

Warning: include_once(): Failed opening 'NetBeansCommandsProvider.php' for inclusion (include_path='C:\Zend\library;.;C:\php5\pear') in C:\Zend\library\Zend\Loader.php on line 146
PHP Fatal error:  Uncaught exception 'Zend_Exception' with message 'File "NetBeansCommandsProvider.php" does not exist or class "NetBeansCommandsProvider" was not found in the file
' in C:\Zend\library\Zend\Loader.php:99
Stack trace:
#0 C:\Zend\library\Zend\Tool\Framework\Loader\BasicLoader.php(110): Zend_Loader::loadClass('NetBeansCommand...')
#1 C:\Zend\library\Zend\Tool\Framework\Client\Abstract.php(122): Zend_Tool_Framework_Loader_BasicLoader->load()
#2 C:\Zend\library\Zend\Tool\Framework\Client\Abstract.php(223): Zend_Tool_Framework_Client_Abstract->initialize()
#3 C:\Zend\bin\zf.php(608): Zend_Tool_Framework_Client_Abstract->dispatch()
#4 C:\Zend\bin\zf.php(117): ZF->_runTool()
#5 C:\Zend\bin\zf.php(74): ZF->run()
#6 C:\Zend\bin\zf.php(632): ZF::main()
#7 {main}
  thrown in C:\Zend\library\Zend\Loader.php on line 99

Fatal error: Uncaught exception 'Zend_Exception' with message 'File "NetBeansCommandsProvider.php" does not exist or class "NetBeansCommandsProvider" was not found in the file' in
C:\Zend\library\Zend\Loader.php:99
Stack trace:
#0 C:\Zend\library\Zend\Tool\Framework\Loader\BasicLoader.php(110): Zend_Loader::loadClass('NetBeansCommand...')
#1 C:\Zend\library\Zend\Tool\Framework\Client\Abstract.php(122): Zend_Tool_Framework_Loader_BasicLoader->load()
#2 C:\Zend\library\Zend\Tool\Framework\Client\Abstract.php(223): Zend_Tool_Framework_Client_Abstract->initialize()
#3 C:\Zend\bin\zf.php(608): Zend_Tool_Framework_Client_Abstract->dispatch()
Alguien mas sabe porque sucede y como solucionarlo , muchas gracias
  #2 (permalink)  
Antiguo 06/03/2010, 06:35
 
Fecha de Ingreso: agosto-2009
Mensajes: 138
Antigüedad: 9 años, 7 meses
Puntos: 0
Respuesta: Error con netbeans

Se puede cerrar el post ,
Realize lo siguiente por si a alguien le sucede lo mismo.
copie la libreria :
NetBeansCommandsProvider.php
dentro de library/zend/ ....y reinicie y se soluciono el problema , despues de instalar y desistarlar netbeans dos veces, supongo que habra sido lo de la librerias,

saludos
  #3 (permalink)  
Antiguo 08/03/2010, 08:41
Avatar de GatorV
$this->role('moderador');
 
Fecha de Ingreso: mayo-2006
Ubicación: /home/ams/
Mensajes: 38.567
Antigüedad: 12 años, 9 meses
Puntos: 2127
Tema movido desde PHP orientado a objetos a Editores Web
  #4 (permalink)  
Antiguo 03/07/2010, 10:46
 
Fecha de Ingreso: diciembre-2009
Mensajes: 27
Antigüedad: 9 años, 3 meses
Puntos: 0
Respuesta: Error con netbeans

¡Hola!
A mí me pasaba lo mismo, lee este post:
https://netbeans.org/bugzilla/show_bug.cgi?format=multiple&id=187234
He editado el archivo ~/.zf.ini cambiando "includepath" por "include_path" y me ha funcionado, no ha sido necesario copiar ningún archivo.

Un saludo,
YY

Última edición por YinYang; 03/07/2010 a las 10:48 Razón: El link no se veía bien (no sé cómo hay que ponerlo)

Etiquetas: editores-web, netbeans
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 00:56.