Foros del Web » Programando para Internet » Jquery »

Conflicto entre versiones diferentes de jquery

Estas en el tema de Conflicto entre versiones diferentes de jquery en el foro de Jquery en Foros del Web. Hola buenas, veran tengo un pequeño problema de incompativilidad de 2 versiones disitintas de jquery. He leido varios post de en este sentido, aquí en ...
  #1 (permalink)  
Antiguo 16/09/2013, 15:32
 
Fecha de Ingreso: mayo-2012
Mensajes: 749
Antigüedad: 8 años, 8 meses
Puntos: 5
Conflicto entre versiones diferentes de jquery

Hola buenas, veran tengo un pequeño problema de incompativilidad de 2 versiones disitintas de jquery.

He leido varios post de en este sentido, aquí en foros del web, pero no me termino de aclarar con mi caso en concreto.

Lo que me pasa es que tengo un jquery que me permite hacer un scrollbar personalizado tanto en forma como color etc.

Y la otra version de jquery me permite hacer un menu para mi web estilo dock de mac.

Pero cuando pongo las dos aplicaciones juntas cada una con su version de jquery , una de ellas no me va.

He probado a ponerlas en la misma version las dos pero no funciona.

Ni tansiquiera en la ultima version estable.

Resumiendo funcionan ambas pero cada una en su version en la cual se concibieron.

Ahora bien, he leido que mediante noConflict, esto tendría arreglo.

Pero no se como hacerlo.

Si alguien pudiera echarme una mano se lo agradeceria enormente:

Para el menu dock estoy poniendo:

Código Javascript:
Ver original
  1. jquery.js
  2. interface_dock.js

y para el scroll:

Código Javascript:
Ver original
  1. jquery-1.9.1.min.js
  2. jquery.mCustomScrollbar.concat.min.js

Saludos.

Etiquetas: conflicto, funcion, javascript, js, versiones
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 08:45.