Foros del Web » Programando para Internet » PHP »

$_SESSION y register_globals no logro trabajar con sesiones

Estas en el tema de $_SESSION y register_globals no logro trabajar con sesiones en el foro de PHP en Foros del Web. Buenas tardes: Ya voy varios dias tratando de trabajar son sesiones pero no logro que funcione. Incluso e usado el autentificador de cluster y tampoco ...
  #1 (permalink)  
Antiguo 01/02/2006, 14:35
Avatar de TheRock  
Fecha de Ingreso: mayo-2002
Ubicación: Sucre - Bolivia
Mensajes: 189
Antigüedad: 15 años, 6 meses
Puntos: 0
Pregunta $_SESSION y register_globals no logro trabajar con sesiones

Buenas tardes:

Ya voy varios dias tratando de trabajar son sesiones pero no logro que funcione.

Incluso e usado el autentificador de cluster y tampoco funciona, entiendo que debe tratarse de alguna directiva que no permite usar estos métodos.

En el script de cluster me sale el siguiente mensaje luego de escribir el login y pass de administrador:

Error cod.: 2 - Acceso incorrecto!

Trabajando con mis scripts e intentado por todo lado recuperar las variables que pasa de una página a la otra y no obtengo ningun dato.

al ejecutar el phpinfo() obtengo estos valores tal vez haya qe modificar alguno, cabe la pena mensionar que trabaja sobre OpenBSD 3.8

en PHP CORE

register_globals Off Off

en SESSION
session
Session Support enabled
Registered save handlers files user

Directive Local Value Master Value
session.auto_start Off Off
session.bug_compat_42 Off Off
session.bug_compat_warn On On
session.cache_expire 180 180
session.cache_limiter nocache nocache
session.cookie_domain no value no value
session.cookie_lifetime 0 0
session.cookie_path / /
session.cookie_secure Off Off
session.entropy_file no value no value
session.entropy_length 0 0
session.gc_divisor 1000 1000
session.gc_maxlifetime 1440 1440
session.gc_probability 1 1
session.name PHPSESSID PHPSESSID
session.referer_check no value no value
session.save_handler files files
session.save_path /tmp /tmp
session.serialize_handler php php
session.use_cookies On On
session.use_only_cookies Off Off
session.use_trans_sid Off Off


Espero puedan orientarme la forma de solucionar este problema.

Saludos cordiales.
  #2 (permalink)  
Antiguo 01/02/2006, 15:46
Avatar de mauled  
Fecha de Ingreso: marzo-2005
Ubicación: Cd. de México.
Mensajes: 3.001
Antigüedad: 12 años, 9 meses
Puntos: 33
De acuerdo

Pon las variables globales en on, eso lo modificas en php.ini
Te recomendaria que buscaras en las FAQ's del foro este problema ya se ha tratado con anterioridad.
  #3 (permalink)  
Antiguo 02/02/2006, 06:59
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Cita:
Iniciado por mauled
Pon las variables globales en on, eso lo modificas en php.ini
Te recomendaria que buscaras en las FAQ's del foro este problema ya se ha tratado con anterioridad.
Mejor que lo deje a OFF ...

La explicación:
http://www.forosdelweb.com/showthrea...989#post238989

Un saludo,
  #4 (permalink)  
Antiguo 02/02/2006, 07:01
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Según tu configuración de PHP .. estás propagando el SID en cookies sólo.

Esto te obliga a que tu navegador de pruebas acepte cookies y que ningún otro software tipo: antivirus, firewall o equivalente esté bloqueando esas cookies que PHP crea para propagar el SID (Identificador Único de sesión).

Un saludo,
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 15:25.