Foros del Web » Programando para Internet » PHP »

Actualizar Librerias gd en FoxServ

Estas en el tema de Actualizar Librerias gd en FoxServ en el foro de PHP en Foros del Web. Hola amigos quisiera saber como actualizolas librerias gd si utilic3e el paquete foxserv para instalar apache+php+mysql. Intente eliminando la vieja extension y pegando la nueva ...
  #1 (permalink)  
Antiguo 24/07/2003, 12:12
Avatar de neoven  
Fecha de Ingreso: enero-2002
Ubicación: La red
Mensajes: 207
Antigüedad: 15 años, 11 meses
Puntos: 0
Actualizar Librerias gd en FoxServ

Hola amigos quisiera saber como actualizolas librerias gd si utilic3e el paquete foxserv para instalar apache+php+mysql. Intente eliminando la vieja extension y pegando la nueva en la carpeta de donde carga las extensiones pero me da error.

Gracias de Antemano
  #2 (permalink)  
Antiguo 25/07/2003, 23:21
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Normalmente .. las librerias GD (y cualquier otra) para windows (los php_xxxx.dll) se "pre-compilan" para la versión de PHP en la que se distribuyen .. (creo que si "le pegas el cambiazo" .. te dará algún error acerca de las versiones de tu PHP y de la extensión que instales ..)

Por lo tanto .. lo ideal es que de "paso" te acualizes la versión de PHP .. para ello (si no quieres instalar otra versión del ForxServ ese .. ) mejor instala PHP manualmente (y de paso aprendes a configurar y "afinar" PHP a tus gustos/necesidades) ...

Para esto último puedes seguir la guía de instalación de:


Y a todo esto .. revisa en tu php.ini y /extensions (directorio) si dispones de php_gd2.dll .. si es así .. habilita esta última y deshabilita php_gd.dll (el ; delante de extension=php_xxx.dll indica que está deshabilitada .. si lo quitas la habilitas ..). Te lo comento por qué para PHP 4.3.0 en adelante .. el php_gd.dll incorpora la versión 2.x de GD (y no se llama php_gd2.dll como en otras versiones de PHP ..)

Si haces esto .. pasate un phpinfo() para ver que el cambio fué ejecutado correctamente.

Un saludo,
__________________
Por motivos personales ya no puedo estar con Uds. Fue grato haber compartido todos estos años. Igualmente los seguiré leyendo.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 10:00.