Foros del Web » Programando para Internet » PHP »

Algo me falla. ¿Tengo algún error?

Estas en el tema de Algo me falla. ¿Tengo algún error? en el foro de PHP en Foros del Web. Código: for($i=0;$i<=count($res["TITLE"])-1;$i++){ print "<div class=\"titulo\">›&nbsp;<a href='http://".$res["URI"][$i]."' ONMOUSEOVER=\"window.status='http://www.dominio.com/';return true\" ONFOCUS=\"window.status='http://www.dominio.com/';return true\" ONMOUSEOUT=\"window.status='';return true\">".$res["TITLE"][$i]."</a></div>"; print "<div class=\"descripcion\">".$res["DESCRIPTION"][$i]."</div>"; print "<div class=\"url\">http://www.".$res["URL"][$i]."</div>"; print "<br>"; } Esta es la parte ...
  #1 (permalink)  
Antiguo 04/08/2004, 09:15
 
Fecha de Ingreso: febrero-2003
Mensajes: 67
Antigüedad: 14 años, 9 meses
Puntos: 0
Algo me falla. ¿Tengo algún error?

Código:
for($i=0;$i<=count($res["TITLE"])-1;$i++){
 print "<div class=\"titulo\">›&nbsp;<a href='http://".$res["URI"][$i]."' ONMOUSEOVER=\"window.status='http://www.dominio.com/';return true\" ONFOCUS=\"window.status='http://www.dominio.com/';return true\" ONMOUSEOUT=\"window.status='';return true\">".$res["TITLE"][$i]."</a></div>";
 print "<div class=\"descripcion\">".$res["DESCRIPTION"][$i]."</div>";
 print "<div class=\"url\">http://www.".$res["URL"][$i]."</div>";
 print "<br>";
}
Esta es la parte final de un parser XML en php. Desconozco donde puede estar el error, tampoco estoy seguro si es mio. El caso es que el parseo lo hace correctamente y la integración en mi web es correcta, pero se produce una cosa curiosa en los enlaces (URI), ya que se truncan. Por ejemplo:

Titulo del enlace 1. Al pulsar sobre él debiera ir a http://www.enlace1.com/index.php?id=12345&r=23&a=4567

Pues resulta que se parte el enlace de modo que queda

Titulo del enlace 1. Va dirigido a: http://www.enlace1.com/index.php?id=12345

Titulo del enlace 2. Va dirigido a: &

Titulo del enlace 3. Va dirigido a: r=23

Titulo del enlace 4. Va dirigido a: &

Titulo del enlace 5. Va dirigido a: a=4567

Me pueden decir si el fallo es de programación o puede proceder del archivo xml.

Última edición por wood; 04/08/2004 a las 09:16
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 13:02.