Foros del Web » Programando para Internet » PHP »

Alguna solución más practica para GD sobre PHP

Estas en el tema de Alguna solución más practica para GD sobre PHP en el foro de PHP en Foros del Web. Les platico lo que me ha pasado con esta bendita libreria GD. Trabajo con servidores FreeBSD y requiero trabajar con graficos desde PHP. Como ya ...
  #1 (permalink)  
Antiguo 17/01/2004, 00:09
 
Fecha de Ingreso: octubre-2003
Ubicación: Veracruz, México
Mensajes: 169
Antigüedad: 14 años, 1 mes
Puntos: 0
Alguna solución más practica para GD sobre PHP

Les platico lo que me ha pasado con esta bendita libreria GD.
Trabajo con servidores FreeBSD y requiero trabajar con graficos desde PHP. Como ya deben saber FreeBSD trae consigo una aenorme coleccion de ports entre los que se encuentran Apache, MySQL y PHP.
Cuando uso instalación de ports me di cuenta de ke PHP no trai consigo el soprte para GD (checando phpinfo() descubri un without-gd) y se instala como modulo de Apache.
Asi ke baje la libreria GD con sus necesarias JPEG-6B, LIBPNG, Z-LIB y FREETYPE. Y bueno sigo los siguientes pasos:
"Destarear" la libreria Z-lib y teclear ./configure --enable-shared, make y make install
"Destarear" la libreria jpeg6b-lib y teclear ./configure --enable-shared ; make y make install
"Destarear" la libreria libpng y teclear ./configure --enable-shared ; make y make install Pero aki me encontre con la variante de tener ke haxer un make test y make install y me encontre con que libpng.so.4 no se encontraba en el lugar válido.. y no se pudo realizar el make install. Y como ya saben esta libreria es requisito indispensable para GD version 2.0 Por lo que el intento de compilarla de antemano sabia seria fallido. Aunke lo intente.

Busque otra solución más freebsdesca.. Buscar en la colección de ports del FreeBSD. Dichas librerias (aunke de antemano sabia ke las versiones de LIB-PNG y GD eran antiguas (1.2.4 y 1.6) y necesito usar las nuevas (1.2.5 y 2.0.20) Decidi solo no instalar por ports GD. Y todo funcionaba bien hasta ke al momento de la compilación de GD me marco ke no encontraba LIB-PNG (y habia indicado su ubicacion en el configure de GD).

A ultimas que me tuve ke conformar con usar la versión de GD que viene en los ports de FreeBSD. Y PHP ahora si pudo reconocer todos los paramateros.. Sin embargo ahora entre a un predicamento nuevo.. Apache no me reconoce PHP. Para instalar ambos utilice lo siguiente (recomendacion de php.net):

tar xvf apache_1.3.28.tar
tar xvf php-4.3.4.tar
cd apache_1.3.28
./configure --prefix=/www
cd ../php-4.3.4
./configure --with-mysql --with-apache=../apache_1.3.x --enable-ftp
make
make install
cd ../apache_1.3.x
./configure --activate-module=src/modules/php4/libphp4.a
make
make install
cd ../php-4.3.4
cp php.ini-dist /usr/local/lib/php.ini
Editar httpd.conf y añadir: AddType application/x-httpd-php .php

Y pues el resultado es que Apache no reconoce PHP

Alguien tiene alguna recomendación, solución o idea de porque tengo ese problema... Espero ideas yo he llevado mucho tiempo en esto y no entiendo el porque. Soy capaz de considerar cambiar el Sist. Operativo.. (sólo sistemas UNIX)
¿ Que me recomiendan ???

Última edición por ray_rockus; 17/01/2004 a las 00:10
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 21:41.