Foros del Web » Programando para Internet » PHP »

Alojar una página PHP

Estas en el tema de Alojar una página PHP en el foro de PHP en Foros del Web. Hola chicos!! tengo un problema a la hora de alojar en mi servidor una página PHP!! La página implementa la funcionalidad de un administrador de ...
  #1 (permalink)  
Antiguo 05/05/2004, 08:09
 
Fecha de Ingreso: mayo-2004
Mensajes: 101
Antigüedad: 13 años, 7 meses
Puntos: 0
Alojar una página PHP

Hola chicos!!

tengo un problema a la hora de alojar en mi servidor una página PHP!!
La página implementa la funcionalidad de un administrador de fincas, y resulta que cuandoq uiero borrar un registro (ya sea un piso, un recibo, lo que sea...) me salen estos errores:

Warning: Unknown(c:\inetpub\wwwroot\admin\listado.php): failed to open stream: No such file or directory in Unknown on line 0

Warning: (null)(): Failed opening 'c:\inetpub\wwwroot\admin\listado.php' for inclusion (include_path='.;c:\php4\pear') in Unknown on line 0

La ruta que aparece en los mensajes de error, son rutas que desconozco, es decir ahí no está alojada la página web!!!

¿alguien me podría orientar para poder solucionar esto?

muchas gracias!.
  #2 (permalink)  
Antiguo 05/05/2004, 08:14
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Si pones el código que usas tal vez sea mejor para intentar orientarte sobre el problema ..

En principio parece que alguna variable que usas para llamar a otro archivo (include() .. fopen() .. etc) no está tomando el valor esperado y resulta una cadena vacia (string nulo)

un saludo,
__________________
Por motivos personales ya no puedo estar con Uds. Fue grato haber compartido todos estos años. Igualmente los seguiré leyendo.
  #3 (permalink)  
Antiguo 05/05/2004, 08:32
 
Fecha de Ingreso: mayo-2004
Mensajes: 101
Antigüedad: 13 años, 7 meses
Puntos: 0
Hola, añado el codigo para que le pegeis un vistazo pero yo realmente no se de donde se saca esa ruta, ya que no la veo en ningun archivo de configuracion :S

No puede estar esa ruta en algun archivo de configuracion el cual yo no he cambiado ?

Gracias

<?php
include("inc/valida.inc.php");
include("../fijos/inc/conecta.inc.php");
$tabla = "is_propietario";
$campos = "IDPROP, NOMBRE, APELLIDO1, APELLIDO2, TFIJO, TMOVIL";
$ordena = "APELLIDO1";
include("inc/paginacion.inc.php");

?>
<html>
<head>
<title> &gt;&gt; MODULO DE ADMINISTRACION</title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
<link href="css/admin.css" rel="stylesheet" type="text/css">
<script language="JavaScript" type="text/javascript">
<!--
function fjcsMandaForm(elId, accion){
document.formAction.idprop.value = elId;
document.formAction.action = accion;
if(document.formAction.action=="delete.php"){
if(confirm("Vas a BORRAR un PROPIETARIO de la Base de Datos,\nSi este propietario tiene inmuebles de su propiedad, \nestos inmuebles serán eliminados por completo.\nsi estás seguro de ello pulsa Aceptar.\nSi no estás seguro o tienes dudas, pulsa Cancelar")){
document.formAction.submit();
}
}else{
document.formAction.submit();
}
}
-->
</script>
</head>
<body bgcolor="#CC0000" leftmargin="0" topmargin="0" marginwidth="0" marginheight="0">
<center>
<table width="100%" height="100%" border="0" cellpadding="0" cellspacing="0">
<tr>

<td align="center" valign="top">
<center>
<img src="imagen/admin.gif" width="520" height="30"> <BR>
<BR>
</center>
<table width="600" height="400" border="0" align="center" cellpadding="10" cellspacing="0" class="tablaMadre">
<tr>

<td height="35" align="center" valign="top"><span class="titulos">PROPIETARIOS</span>
<?php include("inc/menu.inc.php")?>
</tr>
<tr>
<td align="center" valign="top"><?php echo $txt; ?><br>
<?php
$db = sel();
init_paginacion();
pinta("cabecera");
$consulta = mysql_query("SELECT " . $campos . " FROM " . $tabla . " ORDER BY " . $ordena . " ASC LIMIT ".$from_reg.",".$reg_pag,$db);
if($row = mysql_fetch_array($consulta)){
?>
<form name="formAction" method="post">
<INPUT name="idprop" type="hidden" id="idprop">
<INPUT type="hidden" name="pagina" value="<?php echo 'http://'.$_SERVER['SERVER_NAME'].$_SERVER['PHP_SELF'].'?'?>">
<INPUT type="hidden" name="tabla" value="is_propietario">
<table width="580" border="0" cellspacing="0" cellpadding="0">
<tr>
<td width="50" align="center" class="txt1">ID</td>
<td width="80"> </td>
<td width="200" class="txt1">NOMBRE Y APELLIDOS</td>

<td width="120" align="right" class="txt1">TLF.FIJO</td>

<td width="130" align="right" class="txt1">TLF.MOVIL</td>
</tr>
<tr>
<td colspan="5" class="txt1">&nbsp;</td>
</tr>
<?php
if($_SESSION[nivelacc]==1){
$borrado = 'fjcsMandaForm(' . $row["IDPROP"]. ',\'delete.php\');';
}else{
$borrado = 'alert(\'Solo le está permitido borrar registros a los administradores de la aplicación\');';
}
do{
echo '<tr>';
echo '<td width="50" align="center" class="tablaMadre"><b>&nbsp;'.$row["IDPROP"].'</b></td>';
echo '<td width="80" align="center"><A href="#" onClick="' . $borrado . '"><IMG src="imagen/borra_ico.gif" alt="Eliminar propietario" width="14" height="14" border="0"></A> <A href="#" onClick="fjcsMandaForm(' . $row["IDPROP"]. ',\'modificar_prop.php\')"><IMG src="imagen/edit_ico.gif" alt="Editar datos" width="14" height="14" border="0"></A> <A href="#" onClick="fjcsMandaForm(' . $row["IDPROP"]. ',\'consulta_prop.php\')"><IMG src="imagen/llave_ico.gif" alt="Datos del propietario/a" width="14" height="14" border="0"></A></td>';
echo '<td width="200" class="tablaMadre"><b>&nbsp;'.$row["APELLIDO1"].' '.$row["APELLIDO2"].', '.$row["NOMBRE"].'</b></td>';
echo '<td width="120" align="right" class="tablaMadre"><b>&nbsp;'.$row["TFIJO"].'</b></td>';
echo '<td width="130" align="right" class="tablaMadre"><b>&nbsp;'.$row["TMOVIL"].'</b></td>';
echo '</tr>';
$reg_num++;
}while($row = mysql_fetch_array($consulta));
?> </table></form>
<?php
pinta("menu");
}
?>
</td>
</tr>
</table>

</td>
</tr>
</table>
</center>
</body>
</html>
  #4 (permalink)  
Antiguo 05/05/2004, 12:09
Avatar de MaBoRaK  
Fecha de Ingreso: abril-2003
Ubicación: La Paz - Bolivia
Mensajes: 2.003
Antigüedad: 14 años, 7 meses
Puntos: 35
loading.......


no pusiste ".." dos puntos demas en alguno de los includes?
En alguno de tus includes haces esa llamada al archivo listado.php?
Si es asi entonces revisa ese archivo.



connection closed.
__________________

Maborak Technologies
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 02:56.