Foros del Web » Programando para Internet » PHP »

Apache Error

Estas en el tema de Apache Error en el foro de PHP en Foros del Web. Hola a todos, al poner el siguiente codigo php: if (!isset($PHP_AUTH_USER)){ header("WWW-Authenticate:Basic realm=\"Entrar en esta página\""); Header("HTTP/1.0 401 Unauthorized"); echo "Ha cancelado la operación."; exit; ...
  #1 (permalink)  
Antiguo 18/12/2002, 03:33
 
Fecha de Ingreso: noviembre-2002
Mensajes: 273
Antigüedad: 15 años, 1 mes
Puntos: 0
Apache Error

Hola a todos,

al poner el siguiente codigo php:

if (!isset($PHP_AUTH_USER)){
header("WWW-Authenticate:Basic realm=\"Entrar en esta página\"");
Header("HTTP/1.0 401 Unauthorized");
echo "Ha cancelado la operación.";
exit;
}else{
$server="localhost";
$id = @mysql_connect($server,$PHP_AUTH_USER,$PHP_AUTH_PW );
if ($id){
echo "CONECTED";
$user=$PHP_AUTH_USER;
$login=1;
}else{
echo "NO CONECTED";
}
}

me da el siguiente internal error:

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, [email protected] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Apache/2.0.43 Server at localhost Port 80

Y en el error log me dice lo siguiente:

[Wed Dec 18 10:27:59 2002] [error] [client 127.0.0.1] malformed header from script. Bad header=HTTP/1.0 401 Unauthorized: php.exe


Sin embargo he probado con una versión anterior de Apache y funciona. Es un problema de configuración ó es un BUG de esta versión???

Gracias a todos,

/Mickey

Última edición por mickeyzgz; 18/12/2002 a las 03:37
  #2 (permalink)  
Antiguo 18/12/2002, 06:49
Avatar de Energy  
Fecha de Ingreso: abril-2002
Ubicación: Juangriego, Margarita
Mensajes: 468
Antigüedad: 15 años, 8 meses
Puntos: 0
si mas no recuerdo para usar esas funciones php tiene que estar usandose como modulo de apache y no como cgi por lo que he visto , tendrias que volver a configurar php pero como modulo de apache en tu server



Saludos
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 16:00.