Foros del Web » Programando para Internet » PHP »

Ayuda

Estas en el tema de Ayuda en el foro de PHP en Foros del Web. Hola amigos necesito de su ayuda para solventar un problemita. Estoy haciendo una paginación de una dB, de la siguiente manera Select *from telef where ...
  #1 (permalink)  
Antiguo 21/07/2003, 16:49
 
Fecha de Ingreso: febrero-2003
Ubicación: Guanare
Mensajes: 90
Antigüedad: 14 años, 10 meses
Puntos: 0
Ayuda

Hola amigos necesito de su ayuda para solventar un problemita.

Estoy haciendo una paginación de una dB, de la siguiente manera
Select *from telef where codzona between $ruta1 and $ruta2 and $codmod"; esta variable ya vienen con un dato el hace la paginacion la primera vez pero si hay más de una pagina cuando cargo la seguna pagina me aparece nada más que el formato del encabezado, se que cuando lo envio se esta ejecutando la pagina de nuevo y con el numero de pagina a ejecutar, por ejmplo

http://localhost/pagina.php?pagina=#, ya esta cargada pero el orden de busqueda en la db las variable $ruta1, $ruta2 y $codmod estan completamente vacias.

MI PREGUTA ES COMO LAS MANTEGO EN EL SCRIPT PARA QUE CUANDO CARGUE LAS DEMAS PAGINAS SE MANTENGA EN EL SCRIPT.

P.D. Las variables viene de unos input previamente a la pagina
les agradeceria me ayudaran
  #2 (permalink)  
Antiguo 21/07/2003, 17:35
Ex Colaborador
 
Fecha de Ingreso: junio-2002
Mensajes: 9.091
Antigüedad: 15 años, 6 meses
Puntos: 16
Hola,

Solo tienes que propagar esas variables por las URL de los links:

http://localhost/pagina.php?pagina=#&ruta1=$ruta1&ruta2=$ruta2&codmod=$codmod

Luego solo tienes que recogerlas con el array $_GET. Si el formulario original era POST y recogias con $_POST, ahora primero tendras que mirar si existen en $_POST, y si no existen cogerlas del $_GET

Saludos.
__________________
Josemi

Aprendiz de mucho, maestro de poco.
  #3 (permalink)  
Antiguo 21/07/2003, 17:45
 
Fecha de Ingreso: febrero-2003
Ubicación: Guanare
Mensajes: 90
Antigüedad: 14 años, 10 meses
Puntos: 0
Gracias josemi eso lo hice pero creo que mi error estaba en & que no lo estaba colocando, solo enviaba localhost/pagina.php?pagina=#?ruta1=$ruta1?ruta2=$ruta2?mode lo=$codmod, claro ahora por lo que escribes me di cuenta que hacia falta el amp. para separar las variables, cuando hacia $_GET me lo tomaba como un array completo ahora entiendo bueno asi son las cosas.
Gracias por Postearme
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 04:17.