Foros del Web » Programando para Internet » PHP »

Ayuda con este codigo Upload File

Estas en el tema de Ayuda con este codigo Upload File en el foro de PHP en Foros del Web. Tengo este codigo. Código PHP: $directorio  =  $_SERVER [ 'DOCUMENT_ROOT' ]. '/images/' ;  $ejemplo  =  $directorio . $_FILES [ 'ejemplo' ][ 'name' ];  move_uploaded_file ( ...
  #1 (permalink)  
Antiguo 15/07/2005, 09:51
 
Fecha de Ingreso: junio-2003
Mensajes: 74
Antigüedad: 14 años, 5 meses
Puntos: 1
Ayuda con este codigo Upload File

Tengo este codigo.

Código PHP:
$directorio $_SERVER['DOCUMENT_ROOT'].'/images/'
$ejemplo $directorio.$_FILES['ejemplo']['name']; 
move_uploaded_file($_FILES['ejemplo']['tmp'],$directorio$_FILES 'ejemplo' ][ 'name' ]); 
Siendo "ejemplo" el nombre de mi type=file.

El asunto es que a la base de datos me sube bien la ruta donde va a quedar la imagen o el archivo pero la verdad es que no me sube nada al servidor.

Creo que me falta codigo pero no se que.

Agradesco toda su ayuda es un poco urgente.

Mil gracias
  #2 (permalink)  
Antiguo 15/07/2005, 10:36
Avatar de PabloP  
Fecha de Ingreso: marzo-2005
Mensajes: 83
Antigüedad: 12 años, 8 meses
Puntos: 0
podrías poner el contenido de $_SERVER['COCUMENTO_ROOT'] porfa porque puede ser que al agregarle el "/images/" quede un "/" demas, además verifica que el archivo que quiere subir no pese mas de dos megas y si te da algun error subiendolo, porfa indicalo. a ver si te puedo ayudar.
  #3 (permalink)  
Antiguo 15/07/2005, 10:36
Avatar de maralbust  
Fecha de Ingreso: febrero-2004
Ubicación: Santiago
Mensajes: 578
Antigüedad: 13 años, 9 meses
Puntos: 0
y el form desde donde subes la imagen es "multipart/form-data"


saludos
__________________
..:: NADA SE PIERDE SOLO SE TRANSFORMA ::..
  #4 (permalink)  
Antiguo 15/07/2005, 11:06
 
Fecha de Ingreso: junio-2003
Mensajes: 74
Antigüedad: 14 años, 5 meses
Puntos: 1
Respues

Si, mi formulario es <form action="admin.php" enctype="multipart/form-data" method="post">

No me da ningun error, el formulario tiene varios campos, radiobutton y checkbox, todo se carga perfectamente en la base de datos y en el campo de la imagen me graba esto c:/appserv/www/busk-lo/images/AX-19S.jpg, actualmente estoy trabajando local.

La imagen con la que estoy probando pesa 12 Kb.

Gracias por su ayuda
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 20:35.