Foros del Web » Programando para Internet » PHP »

ayuda con login de usuario

Estas en el tema de ayuda con login de usuario en el foro de PHP en Foros del Web. miren, he hecho un sistema de login bastante basico para que los registrados en mis foros phpBB tengan que hacer login (con nick y pass ...
  #1 (permalink)  
Antiguo 21/03/2004, 14:46
 
Fecha de Ingreso: noviembre-2003
Mensajes: 19
Antigüedad: 14 años
Puntos: 0
ayuda con login de usuario

miren, he hecho un sistema de login bastante basico para que los registrados en mis foros phpBB tengan que hacer login (con nick y pass del foro) para acceder a ciertas partes de mi web...lo que he hecho es por cookies, crear una cookie y tal...el problema es q cuando no esta logueado (osea, no hay cookie) todo correcto, pero qando la cookie existe, muestra la pagina correctamente, cuando lo abro directamente (osea, si la pagina es identificado1.php) me sale bien, pero si la meto en un include, me la abre bien tambien, pero me da este error:

Cita:
Warning: Cannot modify header information - headers already sent by (output started at /home/virtual/rpghill.com/roms.php:11) in /home/virtual/rpghill.com/login.php on line 13
alguien me puede ayudar? gracias

PD: el error es en la linea 13, que es esta:

Cita:
setcookie("usNick",$HTTP_COOKIE_VARS["usNick"],time()+7776000);

Última edición por slimmer; 21/03/2004 a las 14:47
  #2 (permalink)  
Antiguo 21/03/2004, 15:35
Avatar de Covids0020  
Fecha de Ingreso: septiembre-2003
Ubicación: España
Mensajes: 217
Antigüedad: 14 años, 2 meses
Puntos: 1
Pasa bastante y hay repuestas por todos lados a este asunto gg XD. Lo primero que debes mandar son los cookies, es decir, no debes mandar nada en las cabeceras antes de las cookies, nisiquiera una linea vacia, si haces un include y antes de este ya has enviado código te dará ese error. Más o menos gg.

Un saludo y espero haberte ayudado, busca por google por el error y ya verás ;] .
__________________
"La sabiduría comienza donde acaba el conocimiento". Yaris.
http://www.culturadigital.org
  #3 (permalink)  
Antiguo 21/03/2004, 16:01
 
Fecha de Ingreso: noviembre-2003
Mensajes: 19
Antigüedad: 14 años
Puntos: 0
jeje, muchas gracias, ya consegui resolverlo, no sabia q poniendolo en google apareceria x ahi posibles soluciones... ^_^

solo tengo otro problema, y es que me pone un numero "1" al final del archivo...
no m molesta mucho pero nose porque sale...aki esta el codigo, por si se os ocurre algo...

Cita:
<?php

include("config.php");
include("login.php");

if($logincorrecto)
{
echo include("roms/id1.php");
}
else
{
echo include("formulario.php");
}
?>
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 01:34.