Foros del Web » Programando para Internet » PHP »

ayuda...formularios...no me guarda algunos datos

Estas en el tema de ayuda...formularios...no me guarda algunos datos en el foro de PHP en Foros del Web. saludos... pasa que estoy modificando un formulario, la cosa es que agrege 2 campos que seria rut y giro...me base mas menos en el codigo ...
  #1 (permalink)  
Antiguo 02/06/2005, 12:21
 
Fecha de Ingreso: agosto-2003
Ubicación: santiago, chile
Mensajes: 297
Antigüedad: 14 años, 3 meses
Puntos: 0
ayuda...formularios...no me guarda algunos datos

saludos...
pasa que estoy modificando un formulario, la cosa es que agrege 2 campos que seria rut y giro...me base mas menos en el codigo que estaba hecho para otro campo que el company, ademas en la base de datos dentro de la tabla adress_book(aca estan las datos de la persona) ingrese 2 campos llamandolos entry_company_rut y entry_company_giro , cosa que al ingresar los datos y despues en darle aceptar.. sale ok, pero cuando ingreso a la base de datos, solo me ingresa los otros datos menos el entry_company_rut y entry_company_giro

aca le dejo la parte del codigo para que me puedan clarificar un poco mas las cosas>

Código:
  <tr class="infoBoxContents">
            <td><table border="0" cellspacing="2" cellpadding="2">
              <tr>
                <td class="main"><?php echo ENTRY_COMPANY; ?></td>
                <td class="main"><?php echo tep_draw_input_field('company') . '&nbsp;' . (tep_not_null(ENTRY_COMPANY_TEXT) ? '<span class="inputRequirement">' . ENTRY_COMPANY_TEXT . '</span>': ''); ?>
              </tr>
			   <tr>
			   <td class="main"><?php echo ENTRY_COMPANY_RUT; ?></td>
			   <td class="main"><?php echo tep_draw_input_field('company_rut') . '&nbsp;' . (tep_not_null(ENTRY_COMPANY_TEXT) ? '<span class="inputRequirement">' . ENTRY_COMPANY_RUT_TEXT . '</span>': ''); ?>
			   </tr>
			   <tr>
			   <td class="main"><?php echo ENTRY_COMPANY_GIRO; ?></td>
			   			   <td class="main"><?php echo tep_draw_input_field('company_giro') . '&nbsp;' . (tep_not_null(ENTRY_COMPANY_TEXT) ? '<span class="inputRequirement">' . ENTRY_COMPANY_GIRO_TEXT . '</span>': ''); ?>
			   </tr>
            </table></td>

saben porq no esta ingresando los datos a la bd?

PD> aca codigo completo del archivo>
http://www.geocities.com/byzard/codigo.txt


nos vemos

Última edición por byzard; 02/06/2005 a las 12:32 Razón: aca mas detallado el codigo
  #2 (permalink)  
Antiguo 02/06/2005, 12:58
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Usas un montón de funciones y objetos que no vemos su código .. así que es complicado seguir el código para evaluar que sucede a simple vista ..

Sólo te puedo recomendar que revises bien el nombre de tus "<input>" (del formulario) que generas (si tienes dudas .. usa tu navegador para ver el código HTML generado: ver -> código fuente ...) y revisa donde llegan en tu script (a esos $HTTP_xxx que usas) y como van a parar a tu sentencia SQL para luego ejecutarla (de hecho .. hazte un echo antes de tu proceso de insercción a la BD para ver que valores está tomando y si son correctos).

Un saludo,
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 02:17.