Foros del Web » Programando para Internet » PHP »

Ayuda para un problema

Estas en el tema de Ayuda para un problema en el foro de PHP en Foros del Web. tengo un archivo forma.php, que debe ser llamado desde un boton flash, pero al hacerlo me aparece el texto del codigo en el explorador ( ...
  #1 (permalink)  
Antiguo 28/01/2004, 10:10
Avatar de Gadoki  
Fecha de Ingreso: agosto-2003
Mensajes: 58
Antigüedad: 14 años, 4 meses
Puntos: 0
Pregunta Ayuda para un problema

tengo un archivo forma.php, que debe ser llamado desde un boton flash, pero al hacerlo me aparece el texto del codigo en el explorador ( pueden ver el archivo en http://www.bukaramanga.com/forma.php ) me pueden decir ke tengo ke cambiarle para ke me envie el correo

el codigo y lo de flash es:


<?php
$sfrom=utf8_decode($email); //cuenta que envia
$sdestinatario=utf8_decode($cuentato); //cuenta destino
$ssubject=utf8_decode($elsubject); //subject
$shtml=utf8_decode($elmsg); //mensaje
$sheader="From:".$sfrom."\nReply-To:".$sfrom."\n";
$sheader=$sheader."X-Mailer:PHP/".phpversion()."\n";
$sheader=$sheader."Mime-Version: 1.0\n";
$sheader=$sheader."Content-Type: text/html";
mail($sdestinatario,$ssubject,$shtml,$sheader);
echo"<BR><BR><center><font size=+2>mensaje enviado</font></center>";
?>

en flash se crean los campos de input text con las variables:
email // el campo donde escriben el mail
cuentato // cuenta de destino, donde caen los emails enviados por la forma
elsubject // el subject
elmsg // el mensaje
al boton de enviar:

code:--------------------------------------------------------------------------------on (release) {getURL ("forma.php", "", "POST");}


GRACIAS
__________________
"No estoy de acuerdo con lo que dices, pero defenderé con mi vida tu derecho a expresarlo." ( Voltaire )
  #2 (permalink)  
Antiguo 28/01/2004, 10:14
Avatar de maralbust@netsc  
Fecha de Ingreso: julio-2003
Ubicación: Santiago
Mensajes: 242
Antigüedad: 14 años, 5 meses
Puntos: 0
maestro mio, si ves el cidogo desdeel menu... VER--->CODIGO DE FUENTES...
aparece esto creo que es este tu problema:

&lt;?php<br>
$sfrom=utf8_decode($email); //cuenta que envia<br>
$sdestinatario=utf8_decode($cuentato); //cuenta destino<br>
$ssubject=utf8_decode($elsubject); //subject<br>
$shtml=utf8_decode($elmsg); //mensaje<br>
$sheader=&quot;From:&quot;.$sfrom.&quot;\nReply-To:&quot;.$sfrom.&quot;\n&quot;;<br>

$sheader=$sheader.&quot;X-Mailer:PHP/&quot;.phpversion().&quot;\n&quot;;<br>
$sheader=$sheader.&quot;Mime-Version: 1.0\n&quot;;<br>
$sheader=$sheader.&quot;Content-Type: text/html&quot;;<br>
mail($sdestinatario,$ssubject,$shtml,$sheader);<br >
echo&quot;&lt;BR&gt;&lt;BR&gt;&lt;center&gt;&lt;fo nt size=+2&gt;mensaje enviado&lt;/font&gt;&lt;/center&gt;&quot;;<br>

?&gt;
__________________
"La imaginacion es el limite"
bee-freaks
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 19:09.