Foros del Web » Programando para Internet » PHP »

Ayuda php5

Estas en el tema de Ayuda php5 en el foro de PHP en Foros del Web. Hola buena!! Necesito realizar una aplicacion en php5 ya que ofrece una orientación a objetos más completa que versiones anteriores pero no se que es ...
  #1 (permalink)  
Antiguo 02/08/2004, 07:02
 
Fecha de Ingreso: julio-2004
Mensajes: 17
Antigüedad: 13 años, 5 meses
Puntos: 0
Ayuda php5

Hola buena!!
Necesito realizar una aplicacion en php5 ya que ofrece una orientación a objetos más completa que versiones anteriores pero no se que es lo que debo de instalar para poder programar dicha aplicación.
Alguien me puede echar una mano??
Muchas gracias.
  #2 (permalink)  
Antiguo 02/08/2004, 08:23
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Y en que S.O. vas a instalar PHP 5?

Recuerda también que si bien para desarrollo en tu "casa" puedes instalar cualquier versión de PHP ... en un servicio de hosting común no vas a encontrar las últimas versiones de PHP (5) de momento (tenlo presente por si todo tu trabajo va a acabar en un servicio de hosting común).

Un saludo,
  #3 (permalink)  
Antiguo 02/08/2004, 09:37
 
Fecha de Ingreso: julio-2004
Mensajes: 17
Antigüedad: 13 años, 5 meses
Puntos: 0
Ok, El sistema operativo es windows. Que versión me aconsejas que utilice para programar una aplicación cuyo analisis esta realizado en objetos??
un saludo y gracias
  #4 (permalink)  
Antiguo 02/08/2004, 09:54
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Pues PHP 5, es la mejor opción si te vas a basar en OOP. Pero .. ¿realmente has evaluado otros lenguajes de programación -del lado del servidor-? .. me refiero a Java (JSP y sus Servlets o como se escriba ¬¬), hay lenguaje se programación que son enteramente OOP no como PHP que "sólo" soporta algo de OOP (más standard en PHP 5 eso sí).

La instalación de PHP 5 es igual a PHP 4 salvo que cambian algunos detalles de configuración (sobre todo si vas a usar Mysql).

Puedes seguir esta guía de instalación de PHP 4 (pero usando PHP 5):
http://www.maestrosdelweb.com/editorial/phpmysqlap/


Un saludo,

Última edición por Cluster; 02/08/2004 a las 09:56
  #5 (permalink)  
Antiguo 02/08/2004, 17:13
 
Fecha de Ingreso: julio-2004
Mensajes: 17
Antigüedad: 13 años, 5 meses
Puntos: 0
Ya, preferiria utilizar java ya que por lo menos me manejo mejor que con php que prácticamente no lo he tocado nunca, pero ahora tengo que utilizar php así que no me queda otra.
De ahí la duda de que era mejor. Asi que muchisimas gracias y espero no tener que incordiar mucho con las dudas
  #6 (permalink)  
Antiguo 03/08/2004, 03:42
 
Fecha de Ingreso: julio-2004
Mensajes: 17
Antigüedad: 13 años, 5 meses
Puntos: 0
Alguien me podría aconsejar que versión de mysql, es la adecuada para programar en php5???
  #7 (permalink)  
Antiguo 03/08/2004, 08:36
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Cualquiera .. Mysql es un motor de BD así que si cumple las espectativas de tu aplicación y requerimientos de esta .. a PHP le es "transparente".

Eso sí . fijate bien que soporta Msyql a nivel de SQL standard y funcionalidades ..por qué en Mysql no tienese ni Store procedure .. ni triggers .. ni sub-consultas y apenas soporte de "integridad referencial".

Usa la última versión estable de Mysql 4.0.x .. (o la que sea estable a día de hoy)

Un saludo,
  #8 (permalink)  
Antiguo 03/08/2004, 09:10
 
Fecha de Ingreso: julio-2004
Mensajes: 17
Antigüedad: 13 años, 5 meses
Puntos: 0
Ya he instalado mysql y he instalado phpmyadmin pero al tratar de acceder a index.php, no me muestra nada. He hecho todo lo que pone en el manual y tengo funcionando tanto mysql como apache. Alguien sabe que es lo que puede estar pasando???
Muchas gracias, un saludo
  #9 (permalink)  
Antiguo 03/08/2004, 09:36
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Pero .. al final instalastes PHP 5?

Si es así ..ya te comenté que hay grandes diferencias para instalar Mysql sobre PHP5 ..

http://www.forosdelweb.com/f18/instalacion-php-5-0-sobre-win32-manual-apache-2-50-a-217240/

Un saludo,
  #10 (permalink)  
Antiguo 04/08/2004, 08:08
 
Fecha de Ingreso: julio-2004
Mensajes: 17
Antigüedad: 13 años, 5 meses
Puntos: 0
Si, finalmente he instalado Php5.Al final he conseguido que me funcionase todo gracias al link que me facilitaste. Así que mucha gracias.
Un saludo
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 05:49.