Foros del Web » Programando para Internet » PHP »

ayuda, please!!!!!

Estas en el tema de ayuda, please!!!!! en el foro de PHP en Foros del Web. Hola a [email protected]! Soy nuevo en esto y necesito toda la ayuda del mundo (y si pudiera ser un pokito mas). Resulta que he estado ...
  #1 (permalink)  
Antiguo 23/07/2002, 12:54
 
Fecha de Ingreso: julio-2002
Mensajes: 54
Antigüedad: 15 años, 4 meses
Puntos: 0
ayuda, please!!!!!

Hola a [email protected]!
Soy nuevo en esto y necesito toda la ayuda del mundo (y si pudiera ser un pokito mas).
Resulta que he estado mirando por aki y por alli y probando todo, todo y todo. Ya he instalado el servidor Apache y PHP siguiendo las instrucciones de las "Memorias de un aprendiz de PHP" como vi en algunos mensajes, pero aun asi no consigo que hacer funcionar PHP (el servidor sí funciona). Imagino que será porque esas instrucciones están hechas para Windows98 y yo tengo Win XP. ¿Alguien me puede ayudar a configurarlo bien?
Gracias ;)

davicillo


¡¡¡¡A por ellos que son pokos y kobardes!!!!
  #2 (permalink)  
Antiguo 23/07/2002, 15:52
Avatar de Yagorat  
Fecha de Ingreso: marzo-2002
Ubicación: Madrid
Mensajes: 161
Antigüedad: 15 años, 8 meses
Puntos: 0
Re: ayuda, please!!!!!

Buenas, yo tengo windows XP, apache y php instalados, atraves de nusphere, y una vez está en marcha el servidor apache, para probar las paginas las pongo en un directorio de apache llamado htdocs, despues desde el navegador pongo la direccion de la página de la siguiente manera
http://localhost/pagina.php

Prueba de esa manera, a ver si asi te funciona, de todas maneras, pon donde te atascas y como instalastes las cosas.

Un saludo a todos.


------------------------
Solo se que no se nada.
Yagorat - Webmaster sin web
  #3 (permalink)  
Antiguo 23/07/2002, 17:07
 
Fecha de Ingreso: julio-2002
Mensajes: 54
Antigüedad: 15 años, 4 meses
Puntos: 0
Re: ayuda, please!!!!!

Claro, yo tambien pongo los archivos en esa carpeta, pero no me funciona. Sin embargo con los archivos .htm si que funciona. Donde me atasco es en la configuración del servidor Apache para que reconozca los .php. Lo hice siguiendo las instrucciones de <a href='ir.asp?http://www.rinconastur.freesurf.fr/php/php3.php' target='_blank'>http://www.rinconastur.freesurf.fr/php/p...</a>. Lo hice todo igual excepto una cosa que no pude hacer: copiar el archivo &quot;php4ts.dll&quot; a &quot;c:\windows\system&quot;. No puedo hacerlo porque no encuentro ese archivo.

davicillo

¡¡¡¡A por ellos que son pokos y kobardes!!!!
  #4 (permalink)  
Antiguo 23/07/2002, 17:24
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Re: ayuda, please!!!!!

Que version de PHP te bajastes? .. (mejor dicho .. q instalacion? ..

Tienes q bajarte la completa (creo q son .. como 5 MBytes .. ) esa icluye esa libreria .dll y extensiones para q puedes configurar tu PHP como Modulo de PHP ..

(es probable que te bajaras la version CGI ..)

Un saludo,
  #5 (permalink)  
Antiguo 24/07/2002, 12:37
 
Fecha de Ingreso: julio-2002
Mensajes: 54
Antigüedad: 15 años, 4 meses
Puntos: 0
Re: ayuda, please!!!!!

El archivo que me bajé es &quot;php-4.3.0-dev-zend2-alpha1.tar.gz&quot; de la pagina oficial de PHP. No sé si será ese el que hay que bajarse, porque como está en inglés, no estoy seguro de si me baje la versión CGI. Si alguien me puede decir si este o es otro, y cúal, se lo agradecería mucho.
Salu2

davicillo


¡¡¡¡A por ellos que son pokos y kobardes!!!!
  #6 (permalink)  
Antiguo 24/07/2002, 12:48
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Re: ayuda, please!!!!!

Parece que usas Windows.. como sistema operativo ..

Bueno . en tal caso bajate esta:
<a href='ir.asp?http://www.php.net/downloads.php' target='_blank'>http://www.php.net/downloads.php...</a>
ahi veras:
en Windows binarys --&gt; PHP 4.2.2 zip package

Esa es la ultima version con todas las extensiones y demas disponibles (son como 5 Megas)

Un saludo,
  #7 (permalink)  
Antiguo 24/07/2002, 13:37
 
Fecha de Ingreso: julio-2002
Mensajes: 54
Antigüedad: 15 años, 4 meses
Puntos: 0
Re: ayuda, please!!!!!

Vale, muchas gracias. Ya lo estoy bajando .
¿Despues que tengo que hacer?¿Solo descomprimir los archivos en la carpeta de Apache y copiar el php4ts.dll a la carpeta de windows\system, o algo mas?
Salu2 ;)

davicillo

¡¡¡¡A por ellos que son pokos y kobardes!!!!
  #8 (permalink)  
Antiguo 25/07/2002, 14:24
 
Fecha de Ingreso: julio-2002
Mensajes: 54
Antigüedad: 15 años, 4 meses
Puntos: 0
Re: ayuda, please!!!!!

Hola!!!
Ya instalé el archivo que me dijisteis, pero sigo sin poder ver PHP, aunque ahora el error es otro. Al intentar abrir un .php me da error interno del servidor. ¿Qué puede pasar?¿Sigo teniendo mal configurado el Apache para php?¿Qué tengo que hacer?
Gracias y salu2. ;)

davicillo

¡¡¡¡A por ellos que son pokos y kobardes!!!!
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 01:47.