Foros del Web » Programando para Internet » PHP »

Ayuda, tengo un problema subiendo imagenes al servidor

Estas en el tema de Ayuda, tengo un problema subiendo imagenes al servidor en el foro de PHP en Foros del Web. Necesito a alguien que me ayude, la pagina insertar del codigo que voy a mostrar ahora me da el siguiente error, sube solamente 2 imagenes, ...
  #1 (permalink)  
Antiguo 07/11/2005, 14:11
 
Fecha de Ingreso: abril-2005
Mensajes: 18
Antigüedad: 12 años, 7 meses
Puntos: 0
Ayuda, tengo un problema subiendo imagenes al servidor

Necesito a alguien que me ayude, la pagina insertar del codigo que voy a mostrar ahora me da el siguiente error, sube solamente 2 imagenes, y las otras 3 me repite la direccion de cualquier de las 2 imagenes, me podrian ayudar con esto? gracias, saludos cualquier cosa me pueden escribir a [email protected]
Código PHP:
<?php 
    
include ("scripts/dbconnection.php");  

    
//Se capturan las variables del formulario.
    
    
$nombre $_POST["nombre"];
    
    
$descripcioncorta $_POST["descripcioncorta"]; $descripcionlarga $_POST["descripcionlarga"];
    
    
$precio $_POST["precio"];
    
    
$foto $_FILES["foto".$a];
    
    
//Se preparan algunas variables.    
    
$random rand(0,10000);
    
$idjpg 'prod'.$random.'.jpeg';
    
$idgif 'prod'.$random.'.gif';
    
    for(
$a=0;$a<5;$a++){

    
//Se envía el archivo al servidor.
    
$tipo_archivo $_FILES['foto'.$a]['type']; 
    
$tamano_archivo $_FILES['foto'.$a]['size'];

    if (
$tipo_archivo == 'image/pjpeg')
        
$nombre_archivo $idjpg;
        
    if (
$tipo_archivo == 'image/gif')
        
$nombre_archivo $idgif;

    if ((
$tipo_archivo!=''))
        {
           if (
move_uploaded_file($HTTP_POST_FILES['foto'.$a]['tmp_name'], "imagenes/productos/$nombre_archivo"))
            
$band=1;    
           else{ echo 
"<b>There's an error. The file couldn't be uploaded.</b>"; } 
     }  
    
$foto='imagenes/productos/'.$nombre_archivo;

if (
$a==0$foto0=$foto;
else if(
$a==1)$foto1=$foto;
else if(
$a==2)$foto2=$foto;
else if(
$a==3)$foto3=$foto;
else if(
$a==4)$foto4=$foto;

}
    
//Preparacion y ejecucion de la consulta
    
$consultaSQL "INSERT INTO productos (id,nombre,descripcioncorta,descripcionlarga,precio,foto0,foto1,foto2,foto3,foto4)
                    VALUES ('','$nombre','$descripcioncorta','$descripcionlarga','$precio','$foto0','$foto1','$foto2','$foto3','$foto4')"
;
      
$resultado mysql_query($consultaSQL) or die("La operación falló;: " mysql_error());
    if (
$resultado)
        echo 
'<META HTTP-EQUIV="refresh" content="5; url=../index.htm">';
    
//Se cierra la conexion 
    
mysql_close($conex); 

?>

Última edición por mandys; 07/11/2005 a las 14:27 Razón: ayuda
  #2 (permalink)  
Antiguo 07/11/2005, 14:52
 
Fecha de Ingreso: abril-2005
Mensajes: 18
Antigüedad: 12 años, 7 meses
Puntos: 0
Lo tengo en 0
echo '<META HTTP-EQUIV="refresh" content="0; url=../index.htm">';
lo que pasa es que mienstras estoy en prueba lo puse asi para ver si la base de datos me da algun error.
  #3 (permalink)  
Antiguo 07/11/2005, 16:04
Avatar de gonzalezmfrank  
Fecha de Ingreso: julio-2005
Ubicación: Maracaibo - Venezuela
Mensajes: 266
Antigüedad: 12 años, 4 meses
Puntos: 0
Prueba insertando el random dentro del for..... estas creando solo dos nombres de archivos

Frank
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 05:59.