Foros del Web » Programando para Internet » PHP »

Ayuda urgente con php en iis

Estas en el tema de Ayuda urgente con php en iis en el foro de PHP en Foros del Web. Instale el php con iis y al tratar de conectarme a mysql con mysql_connect me dice el siguiente error : Fatal error: Call to undefined ...
  #1 (permalink)  
Antiguo 09/10/2004, 17:34
Avatar de akexis  
Fecha de Ingreso: septiembre-2004
Mensajes: 35
Antigüedad: 13 años, 3 meses
Puntos: 0
Ayuda urgente con php en iis

Instale el php con iis y al tratar de conectarme a mysql con mysql_connect me dice el siguiente error :

Fatal error: Call to undefined function mysql_connect() in c:\path\config_db.php on line 13

Se tiene que activar algo en el php para q tome las funciones de mysql ¿?
si me pudieran ayudar por favor ...


Gracias
__________________
Sigan ustedes sabiendo que, mucho más temprano que tarde, de nuevo,
abrirán las grandes alamedas por donde pase el hombre libre, para
construir una sociedad mejor.
  #2 (permalink)  
Antiguo 10/10/2004, 19:59
Avatar de akexis  
Fecha de Ingreso: septiembre-2004
Mensajes: 35
Antigüedad: 13 años, 3 meses
Puntos: 0
ya se lo que paso

Por si alguno le pasa ya se lo que paso les cuento:

Instale la version 5.2 del php y esta ya no viene con las funciones nativas del php , fueron cambiadas por otras funciones desde la version 5 en adelante mas info la encuentran en esta pagina http://cl2.php.net/manual/es/ref.mysql.php

Saludos
__________________
Sigan ustedes sabiendo que, mucho más temprano que tarde, de nuevo,
abrirán las grandes alamedas por donde pase el hombre libre, para
construir una sociedad mejor.
  #3 (permalink)  
Antiguo 12/10/2004, 07:05
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Pero, .. igualmente puedes usar Mysql en PHP 5.x .. tan sólo tienes que tener encuenta que ahora para la versión Windows de PHP 5.x no viene Mysql (las librerias) como "core" (cuerpo) del própio PHP sino que son extensión+librerias .. todo aparte que se ha de habilitar.

En esta guía de instalación de PHP (5 y otras versiones) explica que debes hacer:
http://www.maestrosdelweb.com/editorial/phpmysqlap/#3

Un saludo,
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 15:14.