Foros del Web » Programando para Internet » PHP »

base de dato que no funciona

Estas en el tema de base de dato que no funciona en el foro de PHP en Foros del Web. Buenas. Tengo este scrip para insertar unos registros a una base de datos. <html> <head> <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1"> <title>Documento sin t&iacute;tulo</title> <style type="text/css"> <!-- ...
  #1 (permalink)  
Antiguo 05/10/2004, 16:52
 
Fecha de Ingreso: octubre-2004
Mensajes: 2
Antigüedad: 13 años, 2 meses
Puntos: 0
base de dato que no funciona

Buenas.
Tengo este scrip para insertar unos registros a una base de datos.


<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
<title>Documento sin t&iacute;tulo</title>
<style type="text/css">
<!--
body,td,th {
color: #333333;
}
body {
background-color: #F9F9FF;
}
a {
font-family: Verdana, Arial, Helvetica, sans-serif;
font-size: medium;
}
.Estilo1 {
font-family: Verdana, Arial, Helvetica, sans-serif;
font-size: medium;
}
-->
</style></head>

<body><?php
mysql_connect("localhost","","");
mysql_db_query("db","insert into video(autor, documento, nacimiento, pais, ciudad, educacion, educa, ocupacion,
ampliar, direccion, video1, duracion1, categoria1, formato1, video2, duracion2, categoria2, formato2, video3, duracion3, categoria3, formato3)
values ('$autor', '$documento', '$nacimiento', '$pais', '$ciudad',
'$educacion','$educa','$ocupacion','$ampliar','$di reccion','$video1',
'$duracion1',
'$categoria1','$formato1','$video2','$duracion2',' $categoria2',
'$formato2,'$video3',
'$duracion3','$categoria3','$formato3')");
?>

<p align="center" class="Estilo1">Registro Insertado </p>
</body>
</html>


No sé cuál es el error que tengo por favor colaborenme.

Es urgente
  #2 (permalink)  
Antiguo 05/10/2004, 18:13
 
Fecha de Ingreso: septiembre-2004
Ubicación: Puebla, México
Mensajes: 81
Antigüedad: 13 años, 2 meses
Puntos: 0
No se si escribiste bien tu consulta aqui en el foro, pero si asi la tienes en tu programa, tienes un espacio en la variable direccion, es decir, en vez de '$di reccion' deberia ir '$direccion'. Tambien en formato2 te falta una comita: '$formato2,-> '$formato2',

Espero que esos sean los errores que tengas, saludos
__________________
Revista DdS
Revista on-line sobre desarrollo de software
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 19:02.