Foros del Web » Programando para Internet » PHP »

A cambiar de server PHP_AUTH no me funciona

Estas en el tema de A cambiar de server PHP_AUTH no me funciona en el foro de PHP en Foros del Web. Tengo este código para acceder a una mini administracion web, pero al cambio de server siempre me pregunta la contraseña y haga lo que haga ...
  #1 (permalink)  
Antiguo 04/08/2006, 16:25
Avatar de benti  
Fecha de Ingreso: octubre-2001
Ubicación: Benidorm
Mensajes: 413
Antigüedad: 16 años, 1 mes
Puntos: 0
A cambiar de server PHP_AUTH no me funciona

Tengo este código para acceder a una mini administracion web, pero al cambio de server siempre me pregunta la contraseña y haga lo que haga no la pilla, aunque la cambie.
Código PHP:
 if (($PHP_AUTH_USER!="test") || ($PHP_AUTH_PW!="test")) { 
      
header('WWW-Authenticate: Basic realm="Acceso restringido"'); 
      
header('HTTP/1.0 401 Unauthorized'); 
      echo 
"No tiene acceso a las siguientes páginas."
      exit; 
   } 
Hay alguna alternativa o algo que pueda añadir o decirle al servidor que active para que me funcione de nuevo?

Gracias!
__________________
Seguro que ahora me sale mejor!
  #2 (permalink)  
Antiguo 04/08/2006, 18:01
Avatar de Nefertiter  
Fecha de Ingreso: enero-2003
Ubicación: Rosario
Mensajes: 1.316
Antigüedad: 14 años, 11 meses
Puntos: 8
probaste cambiando el nombre de esas variables, es decir
$PHP_AUTH_USER como $_SERVER['PHP_AUTH_USER'] y $_SERVER['PHP_AUTH_PW'], respectivamente
  #3 (permalink)  
Antiguo 04/08/2006, 19:10
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
El hecho de que no te funcione lo màs probable es por què ahora usas (php.ini directiva): register_globals a OFF y antes la tenìas a ON .. eso hace obligatorio el uso de los arrays superglobables .. no sólo "$_SERVER" sino otras más.

Te recomiendo leer esta FAQ y seguir los links indicados:
http://www.forosdelweb.com/showthrea...989#post238989

Un saludo,
__________________
Por motivos personales ya no puedo estar con Uds. Fue grato haber compartido todos estos años. Igualmente los seguiré leyendo.
  #4 (permalink)  
Antiguo 05/08/2006, 06:07
Avatar de benti  
Fecha de Ingreso: octubre-2001
Ubicación: Benidorm
Mensajes: 413
Antigüedad: 16 años, 1 mes
Puntos: 0
Cita:
Iniciado por Nefertiter Ver Mensaje
probaste cambiando el nombre de esas variables, es decir
$PHP_AUTH_USER como $_SERVER['PHP_AUTH_USER'] y $_SERVER['PHP_AUTH_PW'], respectivamente
Me funciona con tu opcion no obstante leere tb la informacion que Cluster para enterarme un poco más.
Gracias
__________________
Seguro que ahora me sale mejor!
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 19:16.