Foros del Web » Programando para Internet » PHP »

cambio version php 4,0,6 a 4,3,10

Estas en el tema de cambio version php 4,0,6 a 4,3,10 en el foro de PHP en Foros del Web. me han instalado un nuevo servidor con fedora y php 4.3.10 pero hay escripts que no funcionan, hay algun variacion que deba hacer o en ...
  #1 (permalink)  
Antiguo 15/02/2005, 11:00
 
Fecha de Ingreso: agosto-2002
Ubicación: Lleida
Mensajes: 493
Antigüedad: 15 años, 3 meses
Puntos: 0
cambio version php 4,0,6 a 4,3,10

me han instalado un nuevo servidor con fedora y php 4.3.10
pero hay escripts que no funcionan, hay algun variacion que deba hacer o en principio todo debe funcionar igual.
  #2 (permalink)  
Antiguo 15/02/2005, 11:31
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
No .. no todo ha de funciona igual .. recuerda que PHP es altamente configurable así que depende de la configuración de este .. así se comportaran tus aplicaciones en función del código usado.

Por ejemplo .. en PHP 4.0.6 de la época se usaba mucho "asumir" como globales toda variable llamandola (desde el URL o desde formularios por ejemplo .. e incluso sesiones, cookies .. etc) tipo: $variable (sin distinguir de donde llegan: de qué método).

Desde PHP 4.nomeacuerdo-ahora .. viene por "defecto" el uso obligatorio de los arrays supeglobales (forzado por la configuración de (php.ini): register_globals .. a ON .. la cual se puede cambiar para que no tengas -tu- que cambiar tus aplicaciones .. pero ese cambio es para "mejor" (y por tu seguridad) .. Otros cambios son sobre sesiones y algunas funciones que puedan haber cambiado de nombre o desaparecido.

Si muestras el código que plantea el error (concreto: debes indicarlo expresamente) podríamos ver que configuración es la que requieres afinar o bien que código debes cambiar para adaptarte a PHP 4.x (recuerda que ya salió PHP 5 hace un tiempo también .. ).

Un saludo,
  #3 (permalink)  
Antiguo 15/02/2005, 12:23
 
Fecha de Ingreso: agosto-2002
Ubicación: Lleida
Mensajes: 493
Antigüedad: 15 años, 3 meses
Puntos: 0
bueno, estoy comparando con phpinfo() el contenido y veo que hay valores que me han cambiado. voy a ponerlos igual que en el anterior para ver si funciona.
  #4 (permalink)  
Antiguo 15/02/2005, 12:55
 
Fecha de Ingreso: agosto-2002
Ubicación: Lleida
Mensajes: 493
Antigüedad: 15 años, 3 meses
Puntos: 0
Por Si Sirve De Ayuda A Alguien, Todos Los Problemas No Eran De Version Sino De Configuracion Del Php.ini
Graicas
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 14:14.