Foros del Web » Programando para Internet » PHP »

codigo que no inserta en la BD

Estas en el tema de codigo que no inserta en la BD en el foro de PHP en Foros del Web. Hola, llevo ya varios dias dandole vueltas a este problema. Probando cosas,... y no consigo averiguar que narices pasa. La cuesion es que el codigo ...
  #1 (permalink)  
Antiguo 31/01/2005, 05:07
 
Fecha de Ingreso: octubre-2004
Ubicación: Barcelona
Mensajes: 28
Antigüedad: 13 años, 2 meses
Puntos: 0
codigo que no inserta en la BD

Hola, llevo ya varios dias dandole vueltas a este problema. Probando cosas,... y no consigo averiguar que narices pasa.
La cuesion es que el codigo que pasteo a continuacion, deberia insertar el registro en la BD, pero no lo hace ni da ningun error que me pueda ayudar a depurarlo.
La misma consulta hecha en el mysql se completa perfectamente.
Los parametros los recupera bien.
Si alguien ve en que me estoy equivocando le agradeceria mucho su sugerencia.
Gracias.
PD: La url donde deberia funcionar es: http://govinda.no-ip.com/gusmanbukmark/

----------------------- codigo ------------------------
<html>
<head>
<LINK REL=stylesheet TYPE="text/css" HREF="estilo.css">
</head>
<body>
<?
$url=$_POST['url'];
$titulo=$_POST['titulo'];
$descripcion=$_POST['descripcion'];

$servidor = "localhost"; //Servidor donde esta la Base de Datos
$bd = "gusbukmark"; //Nombre de la Base de Datos que contiene la tabla
$tabla = "bookmarks"; //Nombre de la Tabla que queremos acceder
$usuario = "manou"; //Usuario para acceder a la base de datos
$clave = <mypassword>; //Password del usuario para acceder a la base de datos

$mysql_id = mysql_connect($servidor, $usuario, $clave);
$query = "INSERT INTO ". $tabla ." VALUES ('','$url','$titulo','$descripcion','1');";
echo "\n".$query;
mysql_query($query);
mysql_close($mysql_id);
?>
<SCRIPT LANGUAGE="JavaScript">
//setTimeout("location.href='../index.php'", 3000);
</SCRIPT>
</body>
</html>
  #2 (permalink)  
Antiguo 31/01/2005, 05:19
 
Fecha de Ingreso: julio-2004
Mensajes: 31
Antigüedad: 13 años, 4 meses
Puntos: 0
Buenas,

Prueba con

Código PHP:
$query "INSERT $tabla VALUES('','$url','$titulo','$descripcion','1')"
Asi por encima veo un error de sintasix

Código PHP:
;"; 
Venga, a ver si te sirve. Salu2
  #3 (permalink)  
Antiguo 31/01/2005, 05:22
 
Fecha de Ingreso: octubre-2004
Ubicación: Barcelona
Mensajes: 28
Antigüedad: 13 años, 2 meses
Puntos: 0
Si se necesita mas informacion no dudes en pedirmela.
Trabajo con Linux utilizo el php4 con apache 1.3.6 y el SGBD es mySQL.
Un codigo muy parecido funciona perfectamente en http://govinda.no-ip.com/robocup/pri...nistracion.php
  #4 (permalink)  
Antiguo 31/01/2005, 07:52
Avatar de baklao  
Fecha de Ingreso: noviembre-2004
Ubicación: Santa Ana - Isla de Margarita
Mensajes: 482
Antigüedad: 13 años
Puntos: 0
Hola que tal el porque no te inserta en tu tabla es por lo siguiente tienes esto asi:
Código PHP:
$query "INSERT $tabla VALUES('','$url','$titulo','$descripcion','1')"
y deberia ser asi:

Código PHP:
$query "INSERT $tabla (campos de tu tabla) VALUES('','$url','$titulo','$descripcion','1')"
Suerte y Salu2.

Bye
__________________
Atte. Mohamed :aplauso:
  #5 (permalink)  
Antiguo 01/02/2005, 02:25
 
Fecha de Ingreso: octubre-2004
Ubicación: Barcelona
Mensajes: 28
Antigüedad: 13 años, 2 meses
Puntos: 0
Hola de nuevo friends (asi me evito el sentido sexista de amigo o amiga ;)
Agradezco vuestros comentarios, y que hayais dedicado un momento en leer el post y contestar. Sin embargo, ninguna de las dos sugerencias me han solucionado el problema.

De hecho, como dije en el primer post, lo que mas me esta molestando es que la consulta

INSERT INTO bookmarks (id,url,titulo,descripcion,categoria) VALUES ('','enlace','titulo','descripcion','1')

que es el $query que le paso al mySQL (lo que muestra como depurador cuando le damos en insertar en la pagina) , en el phpmyadmin o por cualquier otro sistema (mysql en el prompt),...

se realiza correctamente.

Por eso no entiendo que puede pasar...

Lo que me viene a la cabeza es que se me este pasando por alto alguna opcion en el mysql, pero tengo otro proyecto que utiliza otra BD en el mismo sistema y funciona perfectamente, utilizando practicamente el mismo codigo que el que posteo al principio.

Gracias por la atencion. A ver si lo solucionamos ;)
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 22:04.