Foros del Web » Programando para Internet » PHP »

como habilitar file_get_contents()

Estas en el tema de como habilitar file_get_contents() en el foro de PHP en Foros del Web. Hola al parecer mi servidor dedicado tiene por defecto que no funcionen este tipo de comandos, pues en otro servidor me funciona perfectamente pero en ...
  #1 (permalink)  
Antiguo 20/05/2006, 10:13
 
Fecha de Ingreso: febrero-2003
Mensajes: 753
Antigüedad: 14 años, 10 meses
Puntos: 2
como habilitar file_get_contents()

Hola al parecer mi servidor dedicado tiene por defecto que no funcionen este tipo de comandos, pues en otro servidor me funciona perfectamente pero en el que os comento me sale en blanco (los errrores me salen en blanco, a ver si podeis ayudarme, para saber tambien como habilito los errores de php que no me salen...) probe en un tercer servidor que si tiene lo errores habitados y sale algo asi:

Código PHP:
Warningfile_get_contents() [function.file-get-contents]: URL file-access is disabled in the server configuration in /www/3/site14803/wwwroot/bien.php on line 4

Warning
file_get_contents(http://www.dominio.org/foros/bien.php?perro=bruno&casa=21) [function.file-get-contents]: failed to open stream: no suitable wrapper could be found in /www/3/site14807/wwwroot/bien.php on line 4 
P.D podria conllevar problemas de seguridad el habilitar el file_get_contents() ?¿

Saludos

Última edición por escan_0; 20/05/2006 a las 10:42
  #2 (permalink)  
Antiguo 20/05/2006, 10:40
Avatar de jerkan  
Fecha de Ingreso: septiembre-2005
Mensajes: 1.607
Antigüedad: 12 años, 2 meses
Puntos: 18
Parece que el error no tiene que ver con la función. Por lo que puedo leer no se permite el acceso a ficheros mediante URL. Preguntale a tú servidor a ver qué te puede decir. Suerte.
  #3 (permalink)  
Antiguo 20/05/2006, 10:42
 
Fecha de Ingreso: febrero-2003
Mensajes: 753
Antigüedad: 14 años, 10 meses
Puntos: 2
mi servidor soy yo jeje, tengo una VPS y no se hay que tocar exactamente en el php.ini

saludos
  #4 (permalink)  
Antiguo 20/05/2006, 12:12
 
Fecha de Ingreso: febrero-2003
Mensajes: 753
Antigüedad: 14 años, 10 meses
Puntos: 2
no entiendo porque funcione en un server y otro no...
  #5 (permalink)  
Antiguo 22/05/2006, 11:50
 
Fecha de Ingreso: julio-2003
Ubicación: Buenos Aires
Mensajes: 96
Antigüedad: 14 años, 5 meses
Puntos: 0
al parecer es la directiva allow_url_fopen del php.ini la que hay que habilitar
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 00:03.