Foros del Web » Programando para Internet » PHP »

@$, cómo se usan o como las configuro?

Estas en el tema de @$, cómo se usan o como las configuro? en el foro de PHP en Foros del Web. Hola Gente qué tal? Miren mi problema es el siguiente, tengo un desarrollo que me dio un cliente en PHP, pero las variables en vez ...
  #1 (permalink)  
Antiguo 17/03/2005, 17:22
Avatar de Cbas  
Fecha de Ingreso: enero-2002
Ubicación: capital federal
Mensajes: 437
Antigüedad: 15 años, 11 meses
Puntos: 2
@$, cómo se usan o como las configuro?

Hola Gente qué tal?

Miren mi problema es el siguiente, tengo un desarrollo que me dio un cliente en PHP, pero las variables en vez de ser $variable, son @$variable.

Me dijeron que tengo que tocar el PHP.INI, lo tengo corriendo en un Windows con el IIS.

Alguien sabe qué tengo que tocar?

SALUDOS Y GRACIAS!
__________________
La Perfección es enemigo de lo bueno.
  #2 (permalink)  
Antiguo 17/03/2005, 17:25
Avatar de jam1138
/** @package Moderador */
 
Fecha de Ingreso: julio-2004
Ubicación: sèveR led onieR lE
Mensajes: 9.368
Antigüedad: 13 años, 4 meses
Puntos: 101
¿¿¿???... a menos que me hayan engañado... el anteponer el arroba (@) no es más que para no presentar los errores en pantalla... ... pero tenia idea que era solo para las funciones de MySQL... ...

Entiendo: te pasaron un archivo, lo corres y no se ejecuta??.. algun error? qué hace?? qué no hace???...
__________________
٩(͡๏̯͡๏)۶
» Cómo hacer preguntas de manera inteligente «

"100 años después, la revolución no es con armas, es intelectual y digital"
  #3 (permalink)  
Antiguo 17/03/2005, 17:48
Avatar de Cbas  
Fecha de Ingreso: enero-2002
Ubicación: capital federal
Mensajes: 437
Antigüedad: 15 años, 11 meses
Puntos: 2
Voy a hacer un resumen, porque en realidad hay funciones en includes y todo eso, pero sería un problema explicar todo detalladamente y me parece que no hace a la cuestión.

Estoy pensando... porque viendolo bien, en realidad no me tira error por eso... me tira error por lo siguiente..
Yo tengo así session_register("userid");
y después ghace un llamado a un función
GetValor($userid);
Entonces en es línea me dice Variable Undefined: userid

Será que no tiene el session_start() ???

La verdad no tengo ni idea qué pasa... :(
__________________
La Perfección es enemigo de lo bueno.
  #4 (permalink)  
Antiguo 18/03/2005, 02:13
Ex Colaborador
 
Fecha de Ingreso: junio-2002
Mensajes: 9.091
Antigüedad: 15 años, 5 meses
Puntos: 16
Hola,

Sobre el @: http://www.php.net/manual/en/languag...rorcontrol.php

Cbas, ¿userid es un parametro que viene por URL o de un formulario? Si es asi, creo que el problema es que el script esta programado para funcionar solo con register_globals a ON. Revisa http://www.forosdelweb.com/showpost....89&postcount=4 y la anterior.

saludos.
__________________
Josemi

Aprendiz de mucho, maestro de poco.
  #5 (permalink)  
Antiguo 18/03/2005, 06:32
Avatar de Cbas  
Fecha de Ingreso: enero-2002
Ubicación: capital federal
Mensajes: 437
Antigüedad: 15 años, 11 meses
Puntos: 2
Perfecto, Muchas Gracias Gente! :d
__________________
La Perfección es enemigo de lo bueno.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 01:12.