Foros del Web » Programando para Internet » PHP »

compilar php

Estas en el tema de compilar php en el foro de PHP en Foros del Web. una pregunta q me surge es como puedo compilar PHP bajo windows, ya q lo necesito para activar y desactivar algunas opciones. un ejemplo, en ...
  #1 (permalink)  
Antiguo 19/09/2003, 14:03
 
Fecha de Ingreso: marzo-2003
Ubicación: Argentina
Mensajes: 49
Antigüedad: 14 años, 9 meses
Puntos: 0
compilar php

una pregunta q me surge es como puedo compilar PHP bajo windows, ya q lo necesito para activar y desactivar algunas opciones.
un ejemplo, en el manual de php me dice q "Antes de poder leer y escribir imágenes en formato jpeg, deberá obtener e instalar jpeg-6b (disponible en ftp://ftp.uu.net/graphics/jpeg/), y después recompilar GD para poder hacer uso de jpeg-6b. También tendrá que compilar PHP con la opción --with-jpeg-dir=/ruta/a/jpeg-6b. "

como es eso de compilar?

salu2
  #2 (permalink)  
Antiguo 19/09/2003, 16:07
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
En PHP para windows .. NO se suelen compilar nada .. Ese tipo de extensiones ya las tienes compiladas en tu PHP versión windows .. son los .dll que tienes en tu directorio /extensions de tu instalación de php: php_xxx.dll

En concreto .. las "extensiones" en PHP para windows NO se compilan .. sino que se "habilitan" (pues ya las tienes compiladas) .. La habilitación la haces en tu php.ini .. busca el apartado de extensions y quita el ; delante de la línea que llama a:

extension=php_gd2.dll

(existe php_dg.dll que corresponde a las versiones GD 1.x y php_gd2.dll que corresponde a GD 2.x versiones ..)

Asegurate de que tu extension_dir (del mismo php.ini) apunte al directorio donde tiens esas php_xxx.dll) .. reinicia tu servidor y pasate un phpinfo() para ver que tengas correctamente "habilitado" dicha extensión ..

El mismo procedimiento es para el resto de extensiones que desees instalar para PHP. (no todas es llegar y quitar el ; .. pues algunas requieren de "dll" extra .. pero en tal caso en la documentación de PHP ya se avisa .. ).

Un saludo,
__________________
Por motivos personales ya no puedo estar con Uds. Fue grato haber compartido todos estos años. Igualmente los seguiré leyendo.
  #3 (permalink)  
Antiguo 20/09/2003, 09:42
 
Fecha de Ingreso: marzo-2003
Ubicación: Argentina
Mensajes: 49
Antigüedad: 14 años, 9 meses
Puntos: 0
gracias!!
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 06:05.