Foros del Web » Programando para Internet » PHP »

Comportamiento extraño de IE frente a codigo

Estas en el tema de Comportamiento extraño de IE frente a codigo en el foro de PHP en Foros del Web. Que tal amigos Me he encontrado con un detalle en un codigo que hize, que solo se produce en Internet explorer 6.0 actualizado 100% y ...
  #1 (permalink)  
Antiguo 31/07/2005, 21:58
 
Fecha de Ingreso: febrero-2002
Ubicación: Chile
Mensajes: 1.573
Antigüedad: 15 años, 9 meses
Puntos: 2
Comportamiento extraño de IE frente a codigo

Que tal amigos

Me he encontrado con un detalle en un codigo que hize, que solo se produce en Internet explorer 6.0 actualizado 100% y no en firefox.


Tengo un archivo llamado "archivo.php"

Si es llamado de esta forma
http://10.1/archivo.php => genera error "el campo ID no es numerico"

Si es llamado de esta otra forma
http://10.1/archivo.php?id=19 => muestra el formulario

Hasta este minuto el comportamiento es normal.


El codigo

Código PHP:
<?


if($_POST['Enviar'] != "Enviar")    



 if(!
is_numeric($_GET[id]))
 {
 die(
"Debe introducir un valor numerico en el campo ID");
 exit;
 }
?>
<form method="post" action="archivo.php">
<input name="categoria" type="text" value="">
<input name="Enviar"  type="submit" value="Enviar">
   
</form>

            
<?

} else    {

if (empty(
$_POST['categoria'])) 
{
die (
"No especifico categoria <br> <A HREF=\"javascript:history.back()\"> Volver Atras </A>");
exit;


}else {
$categoria stripslashes($_POST['categoria']);
echo 
$categoria;
         }
               }
              
              
?>

¿donde radica el problema?

si lo llamo de forma correcta (archivo.php?id=19) (o algun numero), me muestra el formulario....

.... si lo relleno en Inet Explorer y presiono "enviar" con el mouse, el sistema lo procesa perfectamente....
.... si lo relleno en Inet Explorer (escribo) y luego presiono enter (sin haber puesto con TAB la seleccion en el boton enviar).... me dice ... Que el campo no es numerico!!!!...
..si me posiciono con tab sobre "enviar" lo procesa perfectamente..

en firefox usando mouse y teclado procesa perfectamente

¿BUG de I explorer??
  #2 (permalink)  
Antiguo 31/07/2005, 22:45
Avatar de claudiovega  
Fecha de Ingreso: octubre-2003
Ubicación: Puerto Montt
Mensajes: 3.667
Antigüedad: 14 años, 1 mes
Puntos: 11
Tu codigo, con esta linea: if($_POST['Enviar'] != "Enviar") está verificando que se haya presionado el boton enviar. No se que sea lo correcto, si al presionar enter ejecutar un submit y enviar la variable como si se hubiera presionado el boton de submit, o hacerlo sólo cuando en verdad se presiona el boton.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 13:22.