Foros del Web » Programando para Internet » PHP »

Condicion con Ñ no funciona

Estas en el tema de Condicion con Ñ no funciona en el foro de PHP en Foros del Web. Hola a todos, para empezar no me funciona el buscador no se si es mi problema o del site. El problema es que tengo una ...
  #1 (permalink)  
Antiguo 30/08/2006, 04:45
Avatar de ZiTAL  
Fecha de Ingreso: marzo-2004
Ubicación: Bermio (Bizkaia)
Mensajes: 1.545
Antigüedad: 13 años, 9 meses
Puntos: 62
Condicion con Ñ no funciona

Hola a todos, para empezar no me funciona el buscador no se si es mi problema o del site.

El problema es que tengo una funcion de validacion que ve si se ha introducido una ñ y no lo reconoce

Código PHP:
if(strtolower($array[i]=="ñ"))
 {
   ?>Has introducido una Ñ<?
 
}
Como se deve de hacer la condicion?
__________________
http://zital.no-ip.org
____________________

Euskerie ahuen eta bijotzan
  #2 (permalink)  
Antiguo 30/08/2006, 04:54
Avatar de ZiTAL  
Fecha de Ingreso: marzo-2004
Ubicación: Bermio (Bizkaia)
Mensajes: 1.545
Antigüedad: 13 años, 9 meses
Puntos: 62
;)

Solucionado, el problema es que strtolower y strtoupper no funcionan con Ñ

Código:
if($array[$i]=="Ñ" || $array[$i]=="ñ")
 {
   ?>Has introducido una Ñ<?
 }
Geroarte!!!!
__________________
http://zital.no-ip.org
____________________

Euskerie ahuen eta bijotzan
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 14:47.