Foros del Web » Programando para Internet » PHP »

Consulta::Mensaje de Error ???

Estas en el tema de Consulta::Mensaje de Error ??? en el foro de PHP en Foros del Web. En un formulario simple que envia correos me aparece luego de enviar este mensaje de error pero envia todo correctamente solamente en lapágina de ocnfirmación ...
  #1 (permalink)  
Antiguo 08/09/2004, 09:41
Avatar de wolf777  
Fecha de Ingreso: junio-2004
Ubicación: Bolivia
Mensajes: 199
Antigüedad: 13 años, 6 meses
Puntos: 0
Pregunta Consulta::Mensaje de Error ???

En un formulario simple que envia correos me aparece luego de enviar este mensaje de error pero envia todo correctamente solamente en lapágina de ocnfirmación sale este detalle:


Notice: Undefined variable: cuerpo in C:\Inetpub\wwwroot\unete\factibilidad\index.php on line 300

Notice: Undefined index: puesta_tierra in C:\Inetpub\wwwroot\unete\factibilidad\index.php on line 316

Alguien sabe a que se debe y conoce la solución???

Lo agradeceria muchisimo

Wolf777
__________________
Do not let The Darknness Get You, to soon...
  #2 (permalink)  
Antiguo 08/09/2004, 09:44
 
Fecha de Ingreso: septiembre-2004
Mensajes: 55
Antigüedad: 13 años, 3 meses
Puntos: 0
La variable no esta definida, pues para que los expertos puedan resolverte te recomiendo que pongas tu codigo desde la lina 300 a la 316 o 320 mas o menos para ver cual es la linea que da el error.
__________________
Proximamente Rincon Ota on line.
  #3 (permalink)  
Antiguo 08/09/2004, 10:16
Avatar de living  
Fecha de Ingreso: mayo-2004
Mensajes: 1.266
Antigüedad: 13 años, 6 meses
Puntos: 2
Mira este post:

http://www.forosdelweb.com/f18/que-tengo-mal-220339/
__________________
¿Te apasiona el mundo del guión? El portal del guión
  #4 (permalink)  
Antiguo 08/09/2004, 10:39
Avatar de wolf777  
Fecha de Ingreso: junio-2004
Ubicación: Bolivia
Mensajes: 199
Antigüedad: 13 años, 6 meses
Puntos: 0
Información

Bueno este es el código.... la verdad funciona muy bien hace todo lo que deberia hacer solo aparece ese error que es muy incomodo y molstoso.

Código PHP:
$fecha =date("l F jS, Y");
$cuerpo .= ":: "$HTTP_POST_VARS["titulo"] ." :: Unete Telecomunicaciones Ltda ::".$fecha."\n";
$cuerpo .= "------------------------\n";
$cuerpo .= "Nombre Vendedor: " $HTTP_POST_VARS["nombrec_vendedor"] . "\n";
$cuerpo .= "Nombre Vendedor: " $HTTP_POST_VARS["tipo_conexion"] . "\n";
$cuerpo .= "Número de Estaciones: "$HTTP_POST_VARS["num_pcs"] . "\n";
$cuerpo .= "Especificar Nº de Estaciones: "$HTTP_POST_VARS["num_pcs_B"] . "\n";
$cuerpo .= "Ancho de Banda: "$HTTP_POST_VARS["ancho_banda"] . "\n"
$cuerpo .= "Otra conexión: "$HTTP_POST_VARS["otro_tipo_conexion"] . "\n";
$cuerpo .= "Nombre Cliente: "$HTTP_POST_VARS["nombrec_cliente"] . "\n";
$cuerpo .= "Empresa: "$HTTP_POST_VARS["empresa"] . "\n";
$cuerpo .= "Contacto Técnico: "$HTTP_POST_VARS["contacto_tecnico"] . "\n";
$cuerpo .= "Teléfono: "$HTTP_POST_VARS["telefono"] . "\n";
$cuerpo .= "Ciudad: "$HTTP_POST_VARS["ciudad"] . "\n";
$cuerpo .= "Zona: "$HTTP_POST_VARS["zona"] . "\n";
$cuerpo .= "Dirección de Instalación: "$HTTP_POST_VARS["direccion_instalacion"] . "\n";
$cuerpo .= "Detalle de Instalación: "$HTTP_POST_VARS["detalle_instalacion"] . "\n";
$cuerpo .= "Puesta a Tierra: "$HTTP_POST_VARS["puesta_tierra"] . "\n";
$cuerpo .= "UPS: "$HTTP_POST_VARS["ups"] . "\n";
$cuerpo .= "Estabilizador: "$HTTP_POST_VARS["estabilizador"] . "\n";
$cuerpo .= "\n\n";
$cuerpo .= "------------------------\n";
$cuerpo2 .= "Esta es una copia de la solicitud de factibilidad enviada por usted,\n proximamanete estaremos en contacto...";
$cuerpo2 .= $cuerpo;
echo 
"\n<html><head><title>Equipos de Telecomunicaciones en Venta</title></head><body><br><font color=\"#003366\" size=\"3\">" $cuerpo "\n</font><br>";
mail("[email protected]","Empresa Ficticia:: Solicitud de Factibilidad :: ".$fecha." ",$cuerpo) or die ("Su mensaje no se envio.");
mail("[email protected]","Empresa Ficticia :: Copía de solicitud de Factibilidad :: ".$fecha." ",$cuerpo2);
?> 


Si alguien puede ver el error seria fantastico, pero escuche comentarios que es la configuración del server y del php mismo que debo modificar....

Saludos

Wolf777
__________________
Do not let The Darknness Get You, to soon...
  #5 (permalink)  
Antiguo 08/09/2004, 10:47
Avatar de living  
Fecha de Ingreso: mayo-2004
Mensajes: 1.266
Antigüedad: 13 años, 6 meses
Puntos: 2
Esto no tiene que ver pero deberías usar $_POST en vez de $HTTP_POST_VARS que está deprecated. El error creo que podría evitarse inicializando $cuerpo:

$cuerpo="";
$cuerpo .= ":: ". $HTTP_POST_VARS["titulo"] ." :: Unete Telecomunicaciones Ltda ::".$fecha."\n";
$cuerpo .= "------------------------\n";
.
.
.
.

Para el otro error leete el post que he puesto antes, ahí te explica la utilización del isset para saber si una variable está definida. De todas maneras son Notices, puedes evitar que salgan modificando el php.ini como se indica en el post que te he puesto
__________________
¿Te apasiona el mundo del guión? El portal del guión
  #6 (permalink)  
Antiguo 08/09/2004, 14:36
Avatar de wolf777  
Fecha de Ingreso: junio-2004
Ubicación: Bolivia
Mensajes: 199
Antigüedad: 13 años, 6 meses
Puntos: 0
Muchas gracias Living. voy a aplicar tus consejos

Bye

Wolf777
__________________
Do not let The Darknness Get You, to soon...
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 05:09.