Foros del Web » Programando para Internet » PHP »

Consulta en varias tablas de la BD sin resultado

Estas en el tema de Consulta en varias tablas de la BD sin resultado en el foro de PHP en Foros del Web. Hola amigos, tengo un problema... hago una consulta en varias tablas de una base de datos, pero cuando quiero que me muestre el resultado no ...
  #1 (permalink)  
Antiguo 19/06/2006, 23:32
 
Fecha de Ingreso: noviembre-2005
Ubicación: Córdoba - Argentina
Mensajes: 155
Antigüedad: 12 años, 1 mes
Puntos: 1
Consulta en varias tablas de la BD sin resultado

Hola amigos, tengo un problema... hago una consulta en varias tablas de una base de datos, pero cuando quiero que me muestre el resultado no lo hace... tampoco tira error.
A continuacion les muestro el codigo.

Código PHP:
<?
$resultado
mysql_query("SELECT campanias507.campania,campanias508.campania,campanias509.campania,campanias_adicionales.campania FROM campanias507, campanias508, campanias509, campanias_adicionales") or die ("Error de conexión: " mysql_error());
while (
$salidamysql_fetch_array($resultado)){


echo 
$salida[campania];
echo 
"<br>";
}

?>
Espero que me puedan ayudar.
Desde ya, muchas gracias!
  #2 (permalink)  
Antiguo 20/06/2006, 00:10
Avatar de turco_7  
Fecha de Ingreso: diciembre-2003
Ubicación: Córdoba, Argentina
Mensajes: 1.044
Antigüedad: 14 años
Puntos: 19
te fijaste que todos los campos se llamas companias ?

probaste poner
echo $salida[compania507.compania];

saludos!
__________________
Mi Blog http://turco7.blogspot.com
Usuario Linux : 404289
Mi última página: http://www.digitalservicecba.com.ar - Reparacion de camaras digitales!
  #3 (permalink)  
Antiguo 20/06/2006, 00:14
 
Fecha de Ingreso: noviembre-2005
Ubicación: Córdoba - Argentina
Mensajes: 155
Antigüedad: 12 años, 1 mes
Puntos: 1
si, son 4 tablas iguales, y yo consulto al primer campo que se llama campania.

Probe de la forma que me decis, pero no me funciono :(
  #4 (permalink)  
Antiguo 20/06/2006, 01:07
Avatar de turco_7  
Fecha de Ingreso: diciembre-2003
Ubicación: Córdoba, Argentina
Mensajes: 1.044
Antigüedad: 14 años
Puntos: 19
Antes que nada hace esto ...

echo $salida["compania507.compania"]; //Agregale las comillas dobles...

te recomiendo que pruebes el SQL en el PHPMyadmin....

si todo anda bien, proba darle alias a los campos, y luego haces asi para imprimir

echo $salida["ALIAS"];

A veces podes llamar con comillas dobles o sin comillas dobles ...

suerte !
__________________
Mi Blog http://turco7.blogspot.com
Usuario Linux : 404289
Mi última página: http://www.digitalservicecba.com.ar - Reparacion de camaras digitales!
  #5 (permalink)  
Antiguo 20/06/2006, 18:48
 
Fecha de Ingreso: noviembre-2005
Ubicación: Córdoba - Argentina
Mensajes: 155
Antigüedad: 12 años, 1 mes
Puntos: 1
Hola turco, estuve probando y de la unica forma que me imprime los resultados es que haga la salida de este modo:

echo $salida[0];

Pero sólo me imprime el resultado cuando tengo el campo campania escrito con algo. Si en una de las ultimas tablas donde hago la consulta no hay informacion, me deja todo en blanco. No tengo idea porque....
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 10:06.