Foros del Web » Programando para Internet » PHP »

cookies

Estas en el tema de cookies en el foro de PHP en Foros del Web. Tengo un cookie que creo con setcookie(); en el servidor que usamos para desarrollo(con php 4.0.6) me lo crea sin problemas, lo uso y anda ...
  #1 (permalink)  
Antiguo 15/03/2002, 09:05
 
Fecha de Ingreso: marzo-2002
Mensajes: 3
Antigüedad: 15 años, 8 meses
Puntos: 0
cookies

Tengo un cookie que creo con setcookie(); en el servidor que usamos para desarrollo(con php 4.0.6) me lo crea sin problemas, lo uso y anda todo bien. Pero cuando lo publico en el servidor que nos hostea (******, con php4.0.3) no me crea el cookie.
Tendrá alguien idea de que puede ser.
Saludos
  #2 (permalink)  
Antiguo 15/03/2002, 11:13
Avatar de Webstudio
Colaborador
 
Fecha de Ingreso: noviembre-2001
Ubicación: 127.0.0.1
Mensajes: 3.499
Antigüedad: 16 años
Puntos: 68
Re: cookies

Creo que los más apropiado sería que te contactes directamente con los responsables de ****** y que les plantees este tema a ellos, ya que no hay motivo aparente por el que no te funcionen las cookies. Eso si, es evidente que esa versión del PHP ya es bastante obsolta y fue uno de los motivos por los que no me decidí a hostear con ellos, porque hace bastante tiempo que tienen esa versión y parece que no tienen pensado actualizarla.

Si necesitas más ayuda, en todo caso postea aquí el código que usas a ver si puede ser otra cosa o te podemos dar alguna idea.

<hr><font size=2 face="verdana">- Pablo Daniel Rigazzi (Webstudio)
<font size=1 color="#333333">COORDINADOR PROYECTO REGIONALIZACION ARGENTINA
Visita <a href="http://www.web-studio.com.ar" target="_blank">Web Studio</a> - Tutoriales Photoshop</fo
  #3 (permalink)  
Antiguo 15/03/2002, 11:33
 
Fecha de Ingreso: marzo-2002
Mensajes: 3
Antigüedad: 15 años, 8 meses
Puntos: 0
Re: cookies

El codigo que uso es este:
$id=md5(uniqid(rand()));
setcookie(&quot;uniqid&quot;, $id,time()+3600);
header( 'Location: http:principalalumno.htm' );
  #4 (permalink)  
Antiguo 15/03/2002, 13:41
Avatar de Webstudio
Colaborador
 
Fecha de Ingreso: noviembre-2001
Ubicación: 127.0.0.1
Mensajes: 3.499
Antigüedad: 16 años
Puntos: 68
Re: cookies

Bueno, primero te diría que intentes seteando TODOS los parámetros de la función setcookie(); ya que a veces algunos navegadores no las soportan si no es de ese modo.

Segundo, te comento que me parece que tu Header() está mal, debería ser de la forma : Header(&quot;Location: archivo.html&quot;); .

Y tercero, quizás este bug que he detectado en IIS (<a href='ir.asp?http://www.forosdelweb.com/mensaje.asp?id=55191' target='_blank'>http://www.forosdelweb.com/mensaje.asp?i...</a>) también sea el culpable de que tu cookie no sea implantada con éxito. Intenta la solución que allí propongo también.

Y si todo eso falla, mandá una carta bomba a ******.


<hr><font size=2 face="verdana">- Pablo Daniel Rigazzi (Webstudio)
<font size=1 color="#333333">COORDINADOR PROYECTO REGIONALIZACION ARGENTINA
Visita <a href="http://www.web-studio.com.ar" target="_blank">Web Studio</a> - Tutoriales Photoshop</fo
  #5 (permalink)  
Antiguo 15/03/2002, 16:08
 
Fecha de Ingreso: marzo-2002
Mensajes: 3
Antigüedad: 15 años, 8 meses
Puntos: 0
Re: cookies

Ya solucioné el inconveniente, había un problema al setear el tiempo de vida del cookie. Gracias por la ayuda. :)
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 20:18.