Foros del Web » Programando para Internet » PHP »

Duda con Sesiones

Estas en el tema de Duda con Sesiones en el foro de PHP en Foros del Web. Hola que tal, estoy haciendo algo para lo que necesito sesiones, ya me puse a leer los manuales que hay en Internet al respecto y ...
  #1 (permalink)  
Antiguo 09/01/2005, 18:45
 
Fecha de Ingreso: enero-2005
Mensajes: 57
Antigüedad: 12 años, 11 meses
Puntos: 0
Duda con Sesiones

Hola que tal, estoy haciendo algo para lo que necesito sesiones, ya me puse a leer los manuales que hay en Internet al respecto y encontre muchas cosas. Ya probe todos los ejemplos (en la red) y funcionan perfectamente, el problema es que al momento de bajar los ejemplos a mi máquina ya no funcionan. =(

Estuve leyendo en el manual oficial de PHP que a partir de la version 4.2 el valor de register_globals es OFF. Supongo que eso tiene que ver porque los ejemplos que baje de la red estan de tal modo que solo funcionan con ese parametro puesto en ON.

Algo así:

<?php
session_register('contador');
echo '<a href="'.$PHP_SELF.'?'.SID.'">Contador vale: '.++$contador.'</a>';
?>

Ahora, leyendo el manual de PHP encontre que hay otra forma de hacerlo con ese parámetro en OFF, que es la siguiente:

<?php
session_start();
if (isset($HTTP_SESSION_VARS['count'])) {
$HTTP_SESSION_VARS['count']++;
}
else {
$HTTP_SESSION_VARS['count'] = 0;
}
?>

o como esto:

<?php
session_start();
if (!isset($_SESSION['count'])) {
$_SESSION['count'] = 0;
} else {
$_SESSION['count']++;
}
?>

Pues bueno, de NINGUNA de las dos formas me funciona. =(

Ya cheque mi configuración con phpinfo() y el valor de register_globals es es ON !!!!!!!

El valor de track_vars no se como verlo. Instale PHP con Appserv y mi versión es la 4.3.0

todo funciona muy bien, solo lo de las sesiones no sale.

¿que puede ser?
  #2 (permalink)  
Antiguo 10/01/2005, 01:59
Ex Colaborador
 
Fecha de Ingreso: junio-2002
Mensajes: 9.091
Antigüedad: 15 años, 6 meses
Puntos: 16
Hola,

¿Tienes configurado para que te muestre los mensajes de error? Son las directivas display_errors y error_reporting. A veces esos instaladores estan configurados para no mostrar errores, quizas este sea tu caso, y este dandote un error y no ves el mensaje por la configuracion.

Uno de los puntos fuertes de PHP es su flexibilidad de configuracion. Y uno de los "problemas" de PHP es su flexibilidad de configuracion. No tengo ni idea de como configura PHP ese instalador. Quizas el problema en tu caso sea de cookies. El id de sesion se debe propagar bien por cookies, o bien por URL. En el ejemplo que pones que te funciona usas la constante SID para propagar el ID de sesion, ¿aparecia en la la URL? En el codigo que no te funciona no pones como propagas el id de sesion. Si lo intenta por cookies, el session_start() debe ir antes de toda salida al navegador.

Saludos.
__________________
Josemi

Aprendiz de mucho, maestro de poco.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 13:47.