Foros del Web » Programando para Internet » PHP »

Duda Faq Webs Modulares

Estas en el tema de Duda Faq Webs Modulares en el foro de PHP en Foros del Web. Hola. Respecto al FAQ webs modulares: <table width="100%" border="0" cellpadding="5"> <tr> <td colspan="2">Cabecera de nuestra Web</td> </tr> <tr> <td><a href="index.php?id=1">Secci&oacute;n 1</a><br> <a href="index.php?id=2">Seccion 2 </a> ...
  #1 (permalink)  
Antiguo 15/09/2003, 15:53
Avatar de Rafael
Modegráfico
 
Fecha de Ingreso: marzo-2003
Mensajes: 8.954
Antigüedad: 14 años, 9 meses
Puntos: 1802
Duda Faq Webs Modulares

Hola. Respecto al FAQ webs modulares:


<table width="100%" border="0" cellpadding="5">
<tr>
<td colspan="2">Cabecera de nuestra Web</td>
</tr>
<tr>
<td><a href="index.php?id=1">Secci&oacute;n 1</a><br>
<a href="index.php?id=2">Seccion 2 </a> </td>
<td>
<?
$id=$_GET['id'];

switch ($id) {
case 1:
include("pagina1.php");
break;
case 2:
include("pagina2.php");
break;
case 3:
include("pagina3.php");
break;
default:
include("pagina_por_defecto.php");
// estado default .. nos determina el estado
// "si no es ninguna opcion de las anteriores".
}
?>
</td>
</tr>
<tr>
<td colspan="2">Pie de p&aacute;gina</td>
</tr>
</table>


sólo funciona la página default, marca error en la barra de estado e internal server error al activar una liga... ¿Alguna alternativa/depuración?.
  #2 (permalink)  
Antiguo 15/09/2003, 16:45
 
Fecha de Ingreso: julio-2002
Mensajes: 322
Antigüedad: 15 años, 5 meses
Puntos: 0
Existen los otros 3 archivos?
__________________
Saludos

Rubén
Teléfonos móviles, curiosidades: http://telefonos-moviles.muchodenada.com/
  #3 (permalink)  
Antiguo 15/09/2003, 19:06
Avatar de LeoIglesias  
Fecha de Ingreso: enero-2003
Ubicación: Concepcion del Uruguay
Mensajes: 53
Antigüedad: 14 años, 11 meses
Puntos: 0
todo parece estar bien

El script es correcto, no tendria que tener problemas. Estas seguro que las paginas pagina1.php, pagina2.php, pagina3.php fueron creadas?

Podrias poner el mensaje de error que te muestra, asi podria ser mas facil....


Saludos
Leo(!)
  #4 (permalink)  
Antiguo 17/09/2003, 12:44
Avatar de Rafael
Modegráfico
 
Fecha de Ingreso: marzo-2003
Mensajes: 8.954
Antigüedad: 14 años, 9 meses
Puntos: 1802
De hecho para que no "haya pierde" todos los archivos se llaman igual, y sólo jala el default. Al activar una liga símplemente sale el típico page not found.

Por el momento no lo puedo poner en un servidor con php, pero dejo un zip a ver si alguien le puede hechar un ojo.

http://www.material1.netfirms.com/modulares.zip

Tiene el archivo modulares.php y un archivo liga.htm para los include.

Gracias.

Última edición por Rafael; 18/09/2003 a las 16:08
  #5 (permalink)  
Antiguo 18/09/2003, 16:09
Avatar de Rafael
Modegráfico
 
Fecha de Ingreso: marzo-2003
Mensajes: 8.954
Antigüedad: 14 años, 9 meses
Puntos: 1802
Tal vez a los novatos como yo les sirva esto.

El error estaba en

<a href="index.php?id=1">Liga</a>

y como mi archivo de prueba era modulares y no index pues no jalaba. Gracias de todos modos.

Última edición por Rafael; 18/09/2003 a las 16:16
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 01:08.