Foros del Web » Programando para Internet » PHP »

Eliminar

Estas en el tema de Eliminar en el foro de PHP en Foros del Web. Hola, aqui os dejo otro de mis problemas. Tengo un formulario en el que presento los registro de una tabla. El formulario lo tengo hecho ...
  #1 (permalink)  
Antiguo 31/01/2006, 09:51
 
Fecha de Ingreso: enero-2006
Mensajes: 32
Antigüedad: 11 años, 10 meses
Puntos: 0
Eliminar

Hola, aqui os dejo otro de mis problemas.
Tengo un formulario en el que presento los registro de una tabla.
El formulario lo tengo hecho con una tabla, entonces en cada fila presento los datos de un registro de la tabla de mysql. Y al lado de cada registro un boton eliminar.
Cada uno de los controles del formulario se llaman como el campo y se le añade un numero. por ejemplo, para el campo componente tengo que cada control se llama componente0, componente1,componente2,... dependiendo de los registros q haya.
Bueno, pues cuando se le de al boton Terminar, quiero uqe me elimine el registro de su misma fila.
Lo intente con un enlace <a href=eliminar.php?reg=$i>Terminar </a> pero de esta manera solo tengo acceso al numero de registro, y no al resto de los campos que se presenta en los controles.
¿Como puedo hacer?
Gracias.
  #2 (permalink)  
Antiguo 31/01/2006, 10:08
Avatar de jerkan  
Fecha de Ingreso: septiembre-2005
Mensajes: 1.607
Antigüedad: 12 años, 2 meses
Puntos: 18
No sé si lo he entendido bien, pero si tienes el número de registro (identificador?) ya no necesitarías nada más para eliminarlo de la base de datos.
Código:
DELETE FROM Tabla WHERE Id = 'numero'
  #3 (permalink)  
Antiguo 31/01/2006, 10:16
Avatar de carlosfocus  
Fecha de Ingreso: enero-2006
Ubicación: Venezuela
Mensajes: 823
Antigüedad: 11 años, 11 meses
Puntos: 0
o si no tambien

DELETE FROM Tabla WHERE ID = '$id'
  #4 (permalink)  
Antiguo 31/01/2006, 10:20
 
Fecha de Ingreso: enero-2006
Mensajes: 32
Antigüedad: 11 años, 10 meses
Puntos: 0
Ya, pero en la tabla no tengo id, pq el tengo dos claves principales, componente y nviga.
Por lo tanto....
  #5 (permalink)  
Antiguo 31/01/2006, 10:24
 
Fecha de Ingreso: enero-2006
Mensajes: 32
Antigüedad: 11 años, 10 meses
Puntos: 0
Da igual, ya lo arregle. Era una tontería, le mando la viga y el componente y ya esta. Gracias de todas maneras.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 01:47.