Foros del Web » Programando para Internet » PHP »

Enviar Mail

Estas en el tema de Enviar Mail en el foro de PHP en Foros del Web. tengo un pequeno problema al tratar de enviar un mail se sale el siguiente error: Warning: mail(): Failed to connect to mailserver at "localhost" port ...
  #1 (permalink)  
Antiguo 27/07/2005, 14:32
 
Fecha de Ingreso: abril-2005
Ubicación: colombia
Mensajes: 242
Antigüedad: 12 años, 7 meses
Puntos: 0
Enviar Mail

tengo un pequeno problema al tratar de enviar un mail se sale el siguiente error:

Warning: mail(): Failed to connect to mailserver at "localhost" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in c:\inetpub\wwwroot\mail.php on line 65

ya configure el php.ini [mail function]

SMTP =localhost
smtp_port = 25

ya arregle en panel de control -herramientas administrativas-servicios de Internet y adicione la ip del servidor que es local.

No se que mas debo hacer para que me funcione.
  #2 (permalink)  
Antiguo 27/07/2005, 15:01
Avatar de _ssx  
Fecha de Ingreso: mayo-2003
Ubicación: mX
Mensajes: 683
Antigüedad: 14 años, 6 meses
Puntos: 60
necesitas instalar un servidor smtp.. prueba el argosoft o el qk smtp server
__________________
Escribe tu código de forma que refleje, y saque a relucir,lo mejor de tu carácter personal
www.oscararzola.com/blog
Principios de un programador
  #3 (permalink)  
Antiguo 29/07/2005, 12:19
 
Fecha de Ingreso: abril-2005
Ubicación: colombia
Mensajes: 242
Antigüedad: 12 años, 7 meses
Puntos: 0
ya instale argosoft y me sale los siguientes errores al dar start que es ????


29/07/2005 12:26:57 - Error starting SMTP server: [10048] Address already in use
29/07/2005 12:26:57 - Error starting POP3 server: [10048] Address already in use
29/07/2005 12:26:57 - Error starting Finger server: [10048] Address already in use


gracias
  #4 (permalink)  
Antiguo 29/07/2005, 12:45
Avatar de _ssx  
Fecha de Ingreso: mayo-2003
Ubicación: mX
Mensajes: 683
Antigüedad: 14 años, 6 meses
Puntos: 60
necesitas cambiar los puertos por default del programa por que esos estan en uso por el IIS, busca en su configuración.. o bien cambialos en el IIS por otros.. los que sean
__________________
Escribe tu código de forma que refleje, y saque a relucir,lo mejor de tu carácter personal
www.oscararzola.com/blog
Principios de un programador
  #5 (permalink)  
Antiguo 29/07/2005, 14:25
 
Fecha de Ingreso: abril-2005
Ubicación: colombia
Mensajes: 242
Antigüedad: 12 años, 7 meses
Puntos: 0
gracias ssx. ya no me sale el error anterior pero ahora me sale esto al ejecutar mi forma.

Warning: mail(): SMTP server response: 554 User not local. Authentication required for relay in c:\inetpub\wwwroot\mail.php on line 65
  #6 (permalink)  
Antiguo 29/07/2005, 14:28
 
Fecha de Ingreso: abril-2005
Ubicación: colombia
Mensajes: 242
Antigüedad: 12 años, 7 meses
Puntos: 0
ya lo solucione, es que tenia activado en argosoft un usuario y un password desactive esta opcion y ya me sirvio muchas gracias SSX
  #7 (permalink)  
Antiguo 29/07/2005, 14:40
 
Fecha de Ingreso: abril-2005
Ubicación: colombia
Mensajes: 242
Antigüedad: 12 años, 7 meses
Puntos: 0
ahora me salio otro problemita, solo puedo enviar correos dentro de mi propia red, hacia afuera no envia gmail,hotmail etc, que debo cambiar o hacer para que me salgan???????????????????????????

Tengo otra pregunta porque tuve que instalar argosoft teniendo instalado iis si este trae el servidor SMTP ??????????????

Última edición por ivomat; 29/07/2005 a las 14:54
  #8 (permalink)  
Antiguo 29/07/2005, 17:15
Avatar de _ssx  
Fecha de Ingreso: mayo-2003
Ubicación: mX
Mensajes: 683
Antigüedad: 14 años, 6 meses
Puntos: 60
Segun yo se.. el servidor SMTP que trae el IIS es utilizado cuando tu pc ya tiene unas DNS y esta digamos registrado como un servidor, creo que esa es la razon.. o más bien por que como yo uso apache :D pues creo fue mayormente mi razon y se me hizo un poco dificil configurar el SMTP de IIS y para poder enviar mails hacia afuera.. solamente debe de ser una configuración del argosoft..
__________________
Escribe tu código de forma que refleje, y saque a relucir,lo mejor de tu carácter personal
www.oscararzola.com/blog
Principios de un programador
  #9 (permalink)  
Antiguo 01/08/2005, 10:26
 
Fecha de Ingreso: abril-2005
Ubicación: colombia
Mensajes: 242
Antigüedad: 12 años, 7 meses
Puntos: 0
gracias ssx, tu siempre tan colaborador, pero no me queda claro porque el stmp de IIS no sirve si alguien sabe por favor una ayudita con eso, ya que en lo que he leido lo tengo configurado bien , pero no me salen .

gracias
__________________
:aplauso: Ivomat
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 17:25.