Foros del Web » Programando para Internet » PHP »

Envio mail con autentificación

Estas en el tema de Envio mail con autentificación en el foro de PHP en Foros del Web. Mi servidor de internet ha cambiado la configuración para el envío de mails mediante PHP utilizaba ini_set(SMTP,"mail.servidor"); ini_set(smtp_port,"25"); mail($EMAIL,$asunto,$mensaje); y todo funcionaba correctamente ahora me ...
  #1 (permalink)  
Antiguo 03/06/2006, 15:27
 
Fecha de Ingreso: abril-2004
Mensajes: 43
Antigüedad: 13 años, 7 meses
Puntos: 0
Envio mail con autentificación

Mi servidor de internet ha cambiado la configuración para el envío de mails mediante PHP

utilizaba

ini_set(SMTP,"mail.servidor");
ini_set(smtp_port,"25");

mail($EMAIL,$asunto,$mensaje);

y todo funcionaba correctamente

ahora me dicen que debo autentificarme.

¿Como se hace la autentificación?

Gracias.
  #2 (permalink)  
Antiguo 03/06/2006, 16:28
 
Fecha de Ingreso: junio-2006
Ubicación: Jáltipan Veracruz, México
Mensajes: 150
Antigüedad: 11 años, 6 meses
Puntos: 1
Me parece que no debe darte problemas.
  #3 (permalink)  
Antiguo 03/06/2006, 16:30
 
Fecha de Ingreso: abril-2004
Mensajes: 43
Antigüedad: 13 años, 7 meses
Puntos: 0
Cita:
Iniciado por norpool1
Me parece que no debe darte problemas.
  #4 (permalink)  
Antiguo 03/06/2006, 16:32
 
Fecha de Ingreso: abril-2004
Mensajes: 43
Antigüedad: 13 años, 7 meses
Puntos: 0
Pues si da problemas. Me sale el siguiente mensaje

warning: mail has been disabled for security reasons
  #5 (permalink)  
Antiguo 03/06/2006, 17:21
 
Fecha de Ingreso: junio-2006
Ubicación: Jáltipan Veracruz, México
Mensajes: 150
Antigüedad: 11 años, 6 meses
Puntos: 1
A ver, porque no instalas un servidor SMTP propio, así tus salidas sería directamente por tu equipo y esquivas a tu servidor de correo
  #6 (permalink)  
Antiguo 03/06/2006, 17:38
 
Fecha de Ingreso: abril-2004
Mensajes: 43
Antigüedad: 13 años, 7 meses
Puntos: 0
Gracias por vuestra colaboración.

He solucionado el problema utilizando la case phpmailer, que es muy facil de configurar.
  #7 (permalink)  
Antiguo 03/06/2006, 18:35
 
Fecha de Ingreso: junio-2006
Ubicación: Jáltipan Veracruz, México
Mensajes: 150
Antigüedad: 11 años, 6 meses
Puntos: 1
instalaste siempre el servidor SMTP?
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 09:30.