Foros del Web » Programando para Internet » PHP »

Error al actualizar de PHP5 a PHP7.3

Estas en el tema de Error al actualizar de PHP5 a PHP7.3 en el foro de PHP en Foros del Web. Buenos días. Tengo un servidor web en Ubuntu con varias páginas web en joomla. Tengo la versión 5.5.6 del php y quiero actualizarla a la ...
  #1 (permalink)  
Antiguo 27/03/2019, 06:16
 
Fecha de Ingreso: julio-2012
Mensajes: 10
Antigüedad: 7 años, 3 meses
Puntos: 0
Error al actualizar de PHP5 a PHP7.3

Buenos días.

Tengo un servidor web en Ubuntu con varias páginas web en joomla. Tengo la versión 5.5.6 del php y quiero actualizarla a la 7.3.

El caso es que la instalación del php la ha hecho bien pero cuando cambio de versión las web me muestran una pantalla donde solo pone ERROR.

El cambio de versión lo hago asi:

sudo a2dismod php5
sudo a2enmod php7.3
sudo service apache2 restart
sudo update-alternatives --set php /usr/bin/php7.3

Me falta por hacer algo? que puede pasar.

Gracias de antemano!
  #2 (permalink)  
Antiguo 27/03/2019, 13:40
 
Fecha de Ingreso: noviembre-2003
Ubicación: Zaragoza, España
Mensajes: 1.257
Antigüedad: 16 años
Puntos: 154
Respuesta: Error al actualizar de PHP5 a PHP7.3

Hola riccardo_moon,

Seguro que esto te lo podrán resolver mejor en el foro de Unix/Linux
  #3 (permalink)  
Antiguo 27/03/2019, 17:20
Avatar de xfxstudios  
Fecha de Ingreso: junio-2015
Ubicación: Valencia - Venezuela
Mensajes: 2.448
Antigüedad: 4 años, 4 meses
Puntos: 263
Respuesta: Error al actualizar de PHP5 a PHP7.3

no es solo actualizar el php base, es tambien verificar las versiones de tus CMS sean compatibles con la nueva version de php
__________________
[email protected]
HITCEL
  #4 (permalink)  
Antiguo 27/03/2019, 22:09
 
Fecha de Ingreso: abril-2006
Mensajes: 314
Antigüedad: 13 años, 6 meses
Puntos: 60
Respuesta: Error al actualizar de PHP5 a PHP7.3

recuerda que varios CMS, fueron hechos para quedarse con cierta version de PHP, y dejan cabos sueltos, no verifican la existencia de funciones, o hacen usa de versiones obsoletas, hay muchos CMS que fueron hechos para 5.5 pero estas usan funciones o extensiones de versiones php 5.1 mismas funciones y extensiones que fueron deshabilitados o eliminados en la version 7, si tienes varios sitios, no salgas de la version 5 de php por que del 5 al 7 ay enormes cambios, y CMS ,Scripts o sistemas PHP que no fueron hechos para ser multicompatible daran error
__________________
Mis aportes te ayudaron??, te hicieron ahorrar valiosos tiempo??, si quieres puedes agradecerme con un Gracias o con una donacion
https://paypal.me/pools/c/87BTML2gwr
  #5 (permalink)  
Antiguo 28/03/2019, 04:07
 
Fecha de Ingreso: julio-2012
Mensajes: 10
Antigüedad: 7 años, 3 meses
Puntos: 0
Respuesta: Error al actualizar de PHP5 a PHP7.3

El log de apache me muestra esto:


[Thu Mar 28 10:17:38.202212 2019] [mpm_prefork:notice] [pid 19843] AH00169: caught SIGTERM, shutting down
[Thu Mar 28 10:17:39.342293 2019] [jk:warn] [pid 27596] No JkShmFile defined in httpd.conf. Using default /var/log/apache2/jk-runtime-status
[Thu Mar 28 10:17:39.386992 2019] [jk:warn] [pid 27597] No JkShmFile defined in httpd.conf. Using default /var/log/apache2/jk-runtime-status
[Thu Mar 28 10:17:39.455483 2019] [mpm_prefork:notice] [pid 27597] AH00163: Apache/2.4.7 (Ubuntu) mod_jk/1.2.37 OpenSSL/1.0.1f configured -- resuming normal operations
[Thu Mar 28 10:17:39.455571 2019] [core:notice] [pid 27597] AH00094: Command line: '/usr/sbin/apache2'
[Thu Mar 28 10:17:50.890131 2019] [php7:warn] [pid 27600] [client 192.168.1.93:53458] PHP Warning: session_start(): Failed to read session data: user (path: /var/lib/php/sessions) in /var/www/intranet/libraries/joomla/session/handler/native.php on line 260


Donde encuentro el log de php?
  #6 (permalink)  
Antiguo 28/03/2019, 06:45
 
Fecha de Ingreso: julio-2012
Mensajes: 10
Antigüedad: 7 años, 3 meses
Puntos: 0
Respuesta: Error al actualizar de PHP5 a PHP7.3

Bueno pues lo he solucionado.

Es un poco cutre pero me ha funcionado. Tenía la versión 5.5.9. De esta versión he pasado a la 5.6, de esta a la 7.0, 7.1, 7.2. y 7.3. Es decir, he ido pasando por todas las versiones y así me ha funcionado.

Etiquetas: php5
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 19:48.